[GeoNode-users] post-installation issues

Simone Dalmasso simone.dalmasso at gmail.com
Tue Sep 29 07:41:15 PDT 2015

Eugenio to debug you can open a python in your virtualenv with
$ python manage.py shell
then try to import the settings with
>>> from django.conf import settings
then see how the MAP_BASELAYERS looks like with
>>> settings.MAP_BASELAYERS

for the second question the answer is yes, geoserver shares the same users
as geonode although it keeps a default admin password that you change both
in the settings and the geoserver users page.

2015-09-29 16:37 GMT+02:00 Eugenio Trumpy <frippe12573 at hotmail.com>:

> Dear all,
> I completed the installation of geonode
> *vs 2.4.dev20150908094256,*I even solved the problem on geoserver and it
> seems to run well.
> I set a geoserver from my organization as external service and
> I'm able to see the layers available. I can see the map of the layer
> and I can use them to prepare maps.
> I tried also to upload a document, and even this function runs well.
> My main problem is on map saving, this operation gives me the 500 internal
> server error.
> By the way the map appears on the list of maps.
> Checking the db (postgres) I see in the maps table the new record,
> however from the map's list I cannot visualize such map, and a new error
> page
> with yellow narrow appears. This page contains many statements*,* these
> three lines
> give an hint on the possible problem:
> Exception Type: IndexError Exception Value:
> list index out of range
> Exception Location: /dati/geonode/geonode/utils.py in viewer_json, line
> 266
> This is my first issue, I got a suggestion (here in the mailing list) to
> debug by python
> console geonode, but unfortunately I don't know how to start.
> Suggestions?
> Another question, might be related to the previous problem, is on
> geoserver authentication:
> I didn't give any password during the installation, and in
> local_setting.py and setting.py
> I see that geoserver has the classical administrator credentials
> (admin,geoserver).
> However if I use the link to geoserver from the user context menu (in the
> geonode website)
> I see the geoserver home page already logged in, but the user logged is
> not admin,
> but the superuser of django. Is that right? Have I set th geoserver
> credential somewhere?
> Thanks for now,
> best regards
> Eugenio
> _______________________________________________
> geonode-users mailing list
> geonode-users at lists.osgeo.org
> http://lists.osgeo.org/cgi-bin/mailman/listinfo/geonode-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20150929/c3d41678/attachment.html>

More information about the geonode-users mailing list