[GeoNode-users] Geonode 2.4 on Ubuntu 16.04

Jonathan Doig j.doig at unsw.edu.au
Tue Nov 1 23:05:04 PDT 2016


I'm trying to install Geonode 2.4 on Ubuntu 16.04, being new to both.

I'm stepping through the OSGeoLive install_geonode.sh script following this advice from Angelos Tzotsos on Aug 18:

Ø  GeoNode 2.4 works fine on Xenial.

Ø  The Debian packaging has been updated accordingly.

Ø  Please check the OSGeoLive install script to find out how to install:

Ø  https://github.com/OSGeo/OSGeoLive/blob/master/bin/install_geonode.sh

However line 50:
apt-get --assume-yes install python-geonode libapache2-mod-wsgi curl

Is giving trouble:
The following packages have unmet dependencies:
python-geonode : Depends: python-django (<= 1.7) but 1.8.7-1ubuntu5.2 is to be installed
                  Recommends: transifex-client but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I think it's because python-geonode is v2.5.5 which uses django 1.8, where I want v2.4 which needs django 1.6.

I tried specifying a geonode version: --target_release '2.4*' or /release or /stable but nothing was found.

Advice please.


Jonathan Doig
Software Engineer - Spatial Systems
City Futures Research Centre
UNSW Built Environment

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20161102/3a002327/attachment-0001.html>

More information about the geonode-users mailing list