[geos-devel] Problems creating polygons with holes

Darren Carman darren.carman at infoterra-global.com
Mon Jun 28 05:15:45 EDT 2004

Hi all,

I am creating polygons with holes and want to use geos to allow me to output them in WKT.

A polygon without a hole works fine, but as soon as I add a hole I get a segmentation fault after calling the createPolygon function (GeometryFactory) and trying to run toString on that polygon.

I am using version 1.0.

I have tried getting the latest version from CVS but this causes a segmentation fault to occur while adding the 5th polygon coordinate to the CoordinateList (there are only 4 coordinates in the test polygon, the 5th being the first one repeated - I tried making it 6 to see if it was a problem with closing the polygon but I still got a segmentation fault while adding the 5th).

Is there a fix for this, or has anyone come accross it?

Thanks in advance,

"The information in this e-mail and any attachment is confidential and may be privileged. If you have received this e-mail in error, please delete it immediately and destroy any copies on your system. You should not retain, copy or use this e-mail for any purpose, nor disclose all or any part of its content to any other person.
Opinions expressed in this e-mail may not be endorsed by the company and unless explicitly indicated, this e-mail shall not form part of any binding agreement".

More information about the geos-devel mailing list