[geos-devel] Error during Make

JC Quirin jc_quirin at hotmail.com
Fri Sep 28 15:47:13 EDT 2007

Hi all...

I'm wondering if anybody can point me towards a solution to this problem.  I'm trying to install Geos (prior to doing PostGIS), but keep getting the same error during the make process.  I'm doing this on a Redhat Enterprise VPS setup where I don't have true root access.  The only parameter I'm changing is the location (by way of "./configure --prefix=/usr/local/geos").

When I run make (or "make check", which is what I just did), it runs for a while but ends with this:
../io/WKBReader.cpp: In function `ostream &geos::WKBReader::printHEX 
(istream &, ostream &)':
../io/WKBReader.cpp:27: `ios_base' undeclared (first use this function)
../io/WKBReader.cpp:27: (Each undeclared identifier is reported only 
once for each function it appears in.)
../io/WKBReader.cpp:27: parse error before `::'
../io/WKBReader.cpp:46: `fl' undeclared (first use this function)
make[2]: *** [WKBReader.lo] Error 1
make[2]: Leaving directory `/usr/home/al-franken/geos-2.2.2/source/geom'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/usr/home/al-franken/geos-2.2.2/source'
make: *** [check-recursive] Error 1

This particular one was using geos 2.2.2 (obviously), but it's the same error no matter which version I've tried (3.0rc4, 2.2.3, 2.2.2, 2.2.1).  Anybody have any ideas?  It's entirely possible I'm missing something very simple.

Thanks in advance...


News, entertainment and everything you care about at Live.com. Get it now!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/geos-devel/attachments/20070928/3f9df2c7/attachment.html

More information about the geos-devel mailing list