[geos-devel] compile on aix

Emre Ersin emree at mobiliz.com.tr
Tue Jun 5 23:32:59 PDT 2012

Ok. I solved it. 

It was because of AIX's assembler command. We made a request to rename
temporarily /usr/bin/as into as_orig and it is solved (solution came
from nmap's documentation).

Now I have a memory exhaustion problem while linking libgeos.a (binutils

-----Original Message-----
From: geos-devel-bounces at lists.osgeo.org
[mailto:geos-devel-bounces at lists.osgeo.org] On Behalf Of Sandro Santilli
Sent: Tuesday, June 05, 2012 11:28 AM
To: GEOS Development List
Subject: Re: [geos-devel] compile on aix

On Mon, Jun 04, 2012 at 07:31:38PM +0300, Emre Ersin wrote:

> g++: internal compiler error: Segmentation fault (program as)
> (It says assembly command "as" gives the fault but I am not sure) 

Yes, it does say that.

> Does anyone have any clue? 

Send a bug report to the GCC team.


  |   __/  |    Delivering high quality PostGIS 2.0 !
  |  / 2.0 |    http://strk.keybit.net - http://vizzuality.com

geos-devel mailing list
geos-devel at lists.osgeo.org

More information about the geos-devel mailing list