[geos-devel] [GEOS] #974: Union of Polylines results in additional segments

GEOS geos-trac at osgeo.org
Mon Jul 8 17:08:45 PDT 2019

#974: Union of Polylines results in additional segments
 Reporter:  jerryfaust  |      Owner:  geos-devel@…
     Type:  defect      |     Status:  new
 Priority:  minor       |  Milestone:
Component:  Default     |    Version:  3.4.2
 Severity:  Unassigned  |   Keywords:  UNION UNARYUNION

 Hopefully I'm overlooking something simple.  I am selecting a group of
 roads.  I want to Union and Buffer them in order to search within the
 resulting polygon.

 However, when I get back the union, there are additional line segments
 that did not exist in the original set.

 I've tried individually Union'ing them, I've tried UnaryUnion of a multi-
 part polyline (MultiLineString). I've also clipper calls.  And I always
 get a similar result.

 I've tried reording the lines as I union them [[Image()]]so that each
 union operation always involves line segments that touch eachother.

 I'm hoping that there is something that I'm simply overlooking, or not
 understanding, or not using properly.

 I'm attaching a snapshot of the circle used to 'select' the streets.  I'm
 expecting a result something like a '#' sign, or tic-tac-toe.  But I get
 additional diagonal lines in the result set.

 Thank you for any feedback.


Ticket URL: <https://trac.osgeo.org/geos/ticket/974>
GEOS <http://trac.osgeo.org/geos>
GEOS (Geometry Engine - Open Source) is a C++ port of the Java Topology Suite (JTS).

More information about the geos-devel mailing list