[GRASS-git] [OSGeo/grass-addons] 90b2b6: style: Standardize parameters and add a Matplotlib...
Paulo van Breugel
noreply at github.com
Sun Aug 2 10:21:10 PDT 2026
Branch: refs/heads/grass8
Home: https://github.com/OSGeo/grass-addons
Commit: 90b2b6dd8a29f7693b01ab3d666afdafa6d1304a
https://github.com/OSGeo/grass-addons/commit/90b2b6dd8a29f7693b01ab3d666afdafa6d1304a
Author: Paulo van Breugel <paulo at ecodiv.earth>
Date: 2026-08-02 (Sun, 02 Aug 2026)
Changed paths:
M src/raster/r.boxplot/r.boxplot.html
M src/raster/r.boxplot/r.boxplot.md
M src/raster/r.boxplot/r.boxplot.py
M src/raster/r.series.boxplot/r.series.boxplot.html
M src/raster/r.series.boxplot/r.series.boxplot.md
M src/raster/r.series.boxplot/r.series.boxplot.py
M src/raster/r.series.boxplot/r_series_boxplot_2.png
M src/temporal/t.rast.boxplot/t.rast.boxplot.html
M src/temporal/t.rast.boxplot/t.rast.boxplot.md
M src/temporal/t.rast.boxplot/t.rast.boxplot.py
M src/temporal/t.rast.line/t.rast.line.md
M src/temporal/t.rast.line/t.rast.line.py
M src/temporal/t.rast.stl/t.rast.stl.html
M src/temporal/t.rast.stl/t.rast.stl.md
M src/temporal/t.rast.stl/t.rast.stl.py
M src/vector/v.boxplot/v.boxplot.html
M src/vector/v.boxplot/v.boxplot.md
M src/vector/v.boxplot/v.boxplot.py
M src/vector/v.boxplot/v_boxplot_02.png
M src/vector/v.histogram/v.histogram.html
M src/vector/v.histogram/v.histogram.md
M src/vector/v.histogram/v.histogram.py
R src/vector/v.histogram/v_histogram.png
A src/vector/v.histogram/v_histogram_01.png
A src/vector/v.histogram/v_histogram_02.png
M src/vector/v.scatterplot/v.scatterplot.html
M src/vector/v.scatterplot/v.scatterplot.md
M src/vector/v.scatterplot/v.scatterplot.py
Log Message:
-----------
style: Standardize parameters and add a Matplotlib style option across plotting addons (#1793)
* Standardize terminology, parameters, and options across plotting addons
Following issue #1071, this PR standardizes parameter names, options, and guisections in five modules. In that issue, there was the question of whether backward compatibility was required. The preference, which I followed, no backward compatibility (i.e., these are breaking for scripts calling the old parameter names).
### Naming convention
Standardised the boxplot parameter family on full words: `bx` → `box` and `lw` → `linewidth`:
* **r.series.boxplot**: `bxcolor` → `box_color`, `boxplot_width` → `box_width`
* **v.boxplot**: `bx_color` → `box_color`, `bx_blcolor` → `box_bordercolor`, `bx_width` → `box_width`, `bx_lw` → `box_linewidth`, `median_lw` → `median_linewidth`
### New parameters
* **`title`** an option in `v.scatterplot`, added to t.rast.line, t.rast.stl, r.series.boxplot, and v.boxplot.Default is no title.
* **`fontsize`** added to t.rast.stl; legend text scales to the base font size.
* **`line_width`** added to t.rast.stl, applied to the series lines.
* **`x_label`** / **`y_label`** overrides added to v.scatterplot (fall back to the column names).
* **r.series.boxplot**: added `box_linewidth`, `median_linewidth`, `median_color`, and `whisker_linewidth`.
* **v.boxplot**: added `whisker_linewidth` (whisker/cap width is now separate from the box border width).
* fixed inconsistencies in manual pages, Including old inconcistencies
* fix manual page, add style sheet option
* Standardization parameter names, update/fix manual pages, added style sheet option
* align parameter names r.boxplot
* align parameter names t.rast.boxplot
* remove end-off-line whitespace
* align parameter names v.histogram
* Apply suggestions from code review
To unsubscribe from these emails, change your notification settings at https://github.com/OSGeo/grass-addons/settings/notifications
More information about the grass-commit
mailing list