[GRASS-git] [OSGeo/grass] 08f30e: tests: Un-shadow duplicated test method names in r...

Tai An noreply at github.com
Fri Sep 18 14:48:30 PDT 2026


  Branch: refs/heads/main
  Home:   https://github.com/OSGeo/grass
  Commit: 08f30e8994dcce1437d4d295cf9d7cdbf8ad9094
      https://github.com/OSGeo/grass/commit/08f30e8994dcce1437d4d295cf9d7cdbf8ad9094
  Author: Tai An <antai12232931 at outlook.com>
  Date:   2026-09-18 (Fri, 18 Sep 2026)

  Changed paths:
    M raster/r.random/testsuite/test_r_random.py
    M temporal/t.rast.gapfill/testsuite/test_gapfill.py

  Log Message:
  -----------
  tests: Un-shadow duplicated test method names in r.random and t.rast.gapfill (#7911)

tests: Un-shadow duplicated test method names

Two gunittest classes define the same test method name twice, so the
earlier definition is overwritten at class-body execution time and never
collected.

raster/r.random: test_random_raster_flag_z and test_vector_random_flag_z
are each defined twice. The first pair writes the "_null" outputs that
tearDownClass already cleans up and is documented as "( with NULL values
)", so it belongs to the -n flag ("Generate points also for NULL cells"),
not -z. Rename it to *_flag_n and pass flags="n". 8 -> 10 collected tests.

temporal/t.rast.gapfill: test_simple_gran is defined twice; the second
passes suffix="time", so name it test_simple_gran_time_suffix, matching
the convention used by t.rast.neighbors and t.rast.accumulate. This
restores the default-suffix test. 5 -> 6 collected tests.

Co-authored-by: Claude Opus 5 (1M context) <noreply at anthropic.com>



To unsubscribe from these emails, change your notification settings at https://github.com/OSGeo/grass/settings/notifications


More information about the grass-commit mailing list