Bernd Munier bernd at tora.ruc.dk
Thu Jun 3 09:40:59 EDT 1993


I encountered a bug in i.points in grass4.1, which already existed in grass4.0,
 but I never managed to fix it  ( we have a calcomp 9100 , grass4.1 running 
under sun-os on a sun sparc IPC). As far as I can see, the problem may be the
same for ortophoto-rectification too ( I never tried this).
The problem is as follows:
Everything works well, until i.points tries to access the digitizing table.
Then i.points crashes and returns to the grass-prompt. See typescript below:
+++++++++++++++++ begin typescript +++++++++++++++++++++++

  The map will have to be registrated to the digitizer:

  On the following screen type the coordinates (Easting/Northing)  of the
  registration points from the map.  There must be at least four registration

  After typing the points hit the escape key <Esc>.

  The next screen will walk thru each set of registration coordinates and you
  will mark each coordinate on the map with the digitizer cursor.

              Hit <RETURN> to continue:
sh: /usr/grass4.1/etc/dig_drivers/none/geo.reg: not found

+++++++++++++++++++++= end typescript +++++++++++++++++++++

Yes, I do have installed the digitizing table in both the new and the old
 way under grass4.1, and as I mentioned the problem is not new with 4.1.

As far as I can see, i.points should look for geo.reg under 'calcomp', not 
under 'none' which is the mouse driver directory. Btw. copying geo.* to 
calcomp doesn't fix the problem.

I tried to install from the binary release for sun4 too, no sucess.

Below a listing of what is the directories:

-rwxrwxr-x  1 bernd       24576 May 18 09:40 /usr/grass4.1/etc/geo.point
-rwxrwxr-x  1 bernd       24576 May 18 09:40 /usr/grass4.1/etc/geo.quest
-rwxrwxr-x  1 bernd       24576 May 18 09:40 /usr/grass4.1/etc/geo.reg
-rwxrwxr-x  1 bernd       24576 May 18 09:40 /usr/grass4.1/etc/geo.unlock
-rwxrwxr-x  1 bernd      360448 May 17 12:01 /usr/grass4.1/etc/dig_drivers/calcomp/digit
-rwxrwxr-x  1 bernd       73728 May 17 12:01 /usr/grass4.1/etc/dig_drivers/calcomp/geo.point
-rwxrwxr-x  1 bernd      139264 May 17 12:01 /usr/grass4.1/etc/dig_drivers/calcomp/geo.reg
-rwxrwxr-x  1 bernd      352256 May 17 11:59 /usr/grass4.1/etc/dig_drivers/none/digit

Hoping anybody has had the same problem and can help

Bernd Munier, Geography, Roskilde Univ. Denmark.

More information about the grass-dev mailing list