Problems with recompiling

Malcolm Williamson malcolm at
Tue May 10 16:46:51 EDT 1994

Steve Culshaw writes:
> Can someone explain to me - fairly simply as I'm not too sure what I'm 
> doing - why I can't get my altered version of to work. This is 
> even more bewildering when my previous change (decreased line thickness) 
> seemed to work ?
> I've found three '' files 
> - one in GRASS/bin - identical in size to all the other programs - 24576 
> bytes- one each in GRASS/etc/bin/alpha/cmd and GRASS/etc/bin/alpha/inter 
> - much bigger
> When I run 'gamke4.1' in the src/alpha/../ directory, I find the 
> /cmd version has been updated, but when I run from in grass, I 
> don't see the changes I've made.
Assuming that you're leaving GRASS up and running while you compile your
altered program, you probably need to execute the "rehash" command from your
GRASS window before you attempt to run the altered

Let me know if this doesn't do the trick.
Malcolm D. Williamson - Research Assistant       E-mail: malcolm at
Center for Advanced Spatial Technologies      Telephone: (501) 575-6159
Ozark Rm. 12                                        Fax: (501) 575-3846 
University of Arkansas              
Fayetteville, AR 72701

More information about the grass-dev mailing list