[GRASS5] grass5install.sh error on mac os x

andy agena andya at mac.com
Wed Feb 14 08:39:23 EST 2001

Hello all:

I received the error below after cat'ing Jeshua's binary pieces.  The installer didn't recognize the cat'ed package as a .tar.gz, when I added the .tar.gz when cat'ing.  Then I tried cat'ing to a file named 'grass5.0beta11_Darwin_bin' and tar'ing and gz'ing it.  This solved the installer's problem with .tar.gz.  Below is the output after running the install script.

Andy Agena

[localhost:/opt/grass5beta11] root# sh grass5install.sh grass5.0beta11_Darwin_bin.tar.gz
GRASS GIS 5 binary package installation tool

Checking and creating installation directory...
Using gunzip decompressor...
The package grass5.0beta11_Darwin_bin.tar.gz seems to be o.k.

Installing GRASS binaries into /usr/local/grass5

Uncompressing the package and extracting to target directory...
grass5install.sh: read-only variable: PWD [217]
Creating start script: /usr/local/bin/grass5
awk: can't open file /usr/local/grass5/grass5
 source line number 7
Creating the locks directory for monitors...
cp: /usr/local/grass5/etc/monitorcap: No such file or directory
grass5install.sh: no such file or directory: /usr/local/grass5/etc/monitorcap [269]

Creating the monitor fifos...
/usr/local/grass5/dev/create_fifos.sh: can't open input file: /usr/local/grass5/dev/create_fifos.sh
Installation finished. Start GRASS 5 with

The graphical user interface can be started within GRASS GIS.

Welcome to GRASS GIS. Enjoy this open source GNU GRASS GIS!

[localhost:/opt/grass5beta11] root# grass5
[localhost:/opt/grass5beta11] root#
If you want to unsubscribe from GRASS Development Team mailing list write to:
minordomo at geog.uni-hannover.de with
subject 'unsubscribe grass5'

More information about the grass-dev mailing list