[GRASS5] [bug #1109] (grass) configure failing to find tcl.h depending on argument order

Request Tracker grass-bugs at intevation.de
Tue Jun 11 13:56:13 EDT 2002

this bug's URL: http://intevation.de/rt/webrt?serial_num=1109

Subject: configure failing to find tcl.h depending on argument order

Platform: GNU/Linux/i386
grass obtained from: Trento Italy site
grass binary for platform: Compiled from Sources
GRASS Version: 5.0pre4

Scott Mitchell   smitchATmac.com:
Trying to update from working grass5.0pre3 to pre4 using freshly 
downloaded source tarball to clean directory, on Debian 3.0 (woody, 
checked for updates today).

configure was bailing looking for tcl.h, even though I specifically told it to 
look in /usr/include/tcl8.3 (where Debian has put it) - I also 
experimented with /usr/include/tk8.3, which debian also has, as well as 
making sure I point to the lib directories too, all with no effect.

This seems like it should be so simple, but I've tried everything I can 
think of.  Archives of the grass5 list mention similar troubles way back 
that were fixed (i.e. Jan 2002 if I remember right);  is it possible a big 
slipped back in to the configure scripts, or am I missing something ?

I started writng this, and then went to check some more things, and 
have found a workaround.  

I first tried bypassing the error using --with-tcltk=no but it seemed to be 
ignored, I got the same error.  Then, on a hunch, tried moving the --with-
tcltk-includes directive earlier in the ./configure command line, and it 
WORKED !?!  Now I'm less sure this is a GRASS bug but will submit it 
here for someone more knowledgeable to judge.
This didn't work:

 ./configure --with-postgres-includes=/usr/local/pgsql/include --with-
postgres-libs=/usr/local/pgsql/lib --with-odbc-libs=/usr/local/lib --with-
odbc-includes=/usr/local/include --with-tcktk-includes=/usr/include/

This DID (and now it's compiling):

 ./configure --with-postgres-includes=/usr/local/pgsql/include --with-
tcltk-includes=/usr/include/tcl8.3/ --with-postgres-libs=/usr/local/pgsql/
lib --with-odbc-libs=/usr/local/lib --with-odbc-includes=/usr/local/include

When there was an error, it logged:

checking whether to use Tcl/Tk... yes
checking for location of Tcl/Tk includes... 
checking for tcl.h... no
configure: error: *** Unable to locate Tcl includes.
bouteloua:/vmware/smitch/grass5.0.0pre4> tail config.log
configure:6978: gcc -o conftest -g -O2    conftest.c -lgd  -lgd   1>&5
configure:7012: checking whether to use Tcl/Tk
configure:7032: checking for location of Tcl/Tk includes
configure:7058: checking for tcl.h
configure:7066: gcc -E   conftest.c >/dev/null 2>conftest.out
configure:7062: tcl.h: No such file or directory
configure: failed program was:
#line 7061 "configure"
#include "confdefs.h"
#include <tcl.h>



-------------------------------------------- Managed by Request Tracker

More information about the grass-dev mailing list