[GRASS5] CVS version of grass5 failing to compile nviz & r.in.gdal because of -ldl flag

Scott W Mitchell smitch at eos.geog.utoronto.ca
Mon Nov 18 15:35:30 EST 2002

Just tried to compile today's CVS version of GRASS5 (is CVS HEAD the 
right terminology if I've just checked out / updated the grass 
directory without specifying any tags?) so I could get the "history 
with r.mapcalc" working.  I've posted separately about the fact that 
r.mapcalc itself won't compile on my Linux box.

But here on my Darwin/MacOS X machine, everything apparently compiled 
(including r.mapcalc, and it's recording the formulae used now - yay !  
Thanks, Glynn !) except for r.in.gdal and NVIZ 2.2.

Digging deeper, the error was the same in both cases - when it tries to 
link everything together there's a lib flag for the DL library (-ldl) 
and libdl isn't found.  IF I understand correctly (and that's a big 
if), libopen() etc are provided by dlcompat in this OS so there is no 
such DL library.

So... I tracked down the -ldl call to the head file, and just made the 
DLLIB variable empty in my copy of head.powerpc-apple-darwin6.1 - and 
then tried to compile NVIZ and it does so without an error.

Is that the appropriate fix ?  NVIZ seems to be working now, anyways.

For some reason, taking the DLLIB definition away doesn't stop the 
compile for r.in.gdal from trying to load libdl so I still have that 
error, but will keep digging for it...


Scott W. Mitchell						    smitch AT geog.utoronto.ca
Department of Geography					
University of Toronto at Mississauga	

More information about the grass-dev mailing list