[GRASS5] [bug #1706] (grass) v.to.db/v.db.reclass weird behaviour?

Request Tracker grass-bugs at intevation.de
Fri Feb 28 20:50:41 EST 2003

this bug's URL: http://intevation.de/rt/webrt?serial_num=1706

Subject: v.to.db/v.db.reclass weird behaviour?

Platform: GNU/Linux/i386
grass obtained from: Trento Italy site
grass binary for platform: Compiled from Sources
GRASS Version: 5.0.1


Using redhat 8.0, postgresql-7.2.3-5.80, compiled unixodbc2.2.5(tried 2.2.2-3 from redhat also). Everything works (isql, pgsql).
As already posted to sqlgrass, v.to.db acts weird. Now I'm not that new to grass  and in the past had never any trouble with this module. Well, I can update the cats (though it's not checking for existing ones) to tables. But with the label, area, count etc options it goes wrong (cat row 1 does not exist). It seems reading the cats in the table goes wrong. Table is constructed with int for cat so there should be no problem. But there is. All other modules with odbc go nicely, list table, select etc. except for v.db.reclass wich does work but writes no vectors (processing, 0 vectors written to map). It seems affected by the same thing. I've checked and tried everything (installing other (previous/newer) versions, compiling myself) but no results. As odbc and postgres are working just fine, the problem doesn't weem to lie there. Well hope you can get it, cause I trying for days now without results.

Greetings Sjors

-------------------------------------------- Managed by Request Tracker

More information about the grass-dev mailing list