[GRASS5] [bug #1709] (grass) problem with r.spread

Request Tracker grass-bugs at intevation.de
Mon Mar 3 03:27:06 EST 2003

this bug's URL: http://intevation.de/rt/webrt?serial_num=1709

Subject: problem with r.spread

Platform: GNU/Linux/i386
grass obtained from: Mirror of Trento site
grass binary for platform: Downloaded precompiled Binaries
GRASS Version: 5.0.0_i686-pc-linux

I am a new GRASS user. My binary Grass 5.0 was downloaded from the University Hannover server and is running on Linux Red Hat 8.0. My computer is a Laptop PC, 256 MB RAM.
The program is running - I did some tutorials and everything worked fine, except r.spread.
I am using this program to study fire simulations. To learn how all this is working in GRASS I downloaded the fire simulation package from the GRASS server. There is a script called firedemo.sh. When I run it, it gives a segmentation fault, after it passed the r.spread function. This also happens, when I run only the r.spread program.
I don't know any C yet, so it is very time consuming to find out, where the problem is. It seems like "replaceHa()" it called a couple of times and than stops with a seg fault.
I can attach a message from gdb.


Reading inputs ... 100%
Reading fire_origin ...  100%
Finding spread time - number of cells visited in percentage ...    0%(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x0804cd50 in replaceHa () 
I know somebody else trying to work with r.spread as well. She had the same problem as me. The odd thing is, she said r.spread worked on the windows port. The windows port is not running on my machine (OS: Windows 2000), but that is another story...

I hope the provided information is sufficient enough to understand my problem.


-------------------------------------------- Managed by Request Tracker

More information about the grass-dev mailing list