[GRASS5] r3.showdspf problems in GRASS 5.7

Michael Barton michael.barton at asu.edu
Wed Aug 25 01:30:15 EDT 2004

I tried again to get r3.showdspf to work without success. I am using the
sample weather dataset and Lorenzo Moretti's binaries under Mac OSX 10.3.5

Problem #1. When I run r3.showdspf via g_gui(), it sends output to the tcltk
output display window--as expected. However, it needs to send output to an
xterm so that you can interact with it. I can script around this in
tcltkgrass menus, but thought I would mention it.

Problem #2. Potentially more serious. When I run r3.showdspf from the
command line 

>>r3showdspf grid3=CloudLCP.992172300 dspf=test

I get the desired prompt. But when I enter any of the normal r3.showdspf
commands (e.g., +, -, d, ?) I get a "Broken pipe" error.

I also get errors when I try to run r3.mkdspf. This generates many errors.
For example....

GRASS 5.7.cvs:~ > r3.mkdspf grid3=CloudLCP.992172300 dspf=cloudtest2 tnum=7
Region from getWindow: 80 100 21

** cloudtest2 exists. ok to overwrite? (y/n) [n] y
rows=80 cols=100 depths=21
threshold values: 0.000000 0.183333 0.366667 0.550000 0.733333 0.916667
No. of thresholds: 8
DSPF DIMS: 80 100 21
Writing cloudtest2 from CloudLCP.992172300...display file completed:ERROR:
ompress_readXdrNums: read error
ERROR: G3d_readTileCompressed: error in G_fpcompress_readXdrNums
ERROR: G3d_readTile: error in G3d_readTileCompressed
ERROR: cacheRead_readFun: error in G3d_readTile
ERROR: G3d_cache_elt_ptr: error in c->eltLoadFun
ERROR: G3d_getTilePtr: error in G3d_cache_elt_ptr
FATAL ERROR: G3d_getFloatRegion: error in G3d_getTilePtr

Any thoughts anyone?
C. Michael Barton, Professor
School of Human Diversity and Social Change
PO Box 872402
Arizona State University
Tempe, AZ  85287-2402

Phone: 480-965-6262
Fax: 480-965-7671
www: <www.public.asu.edu/~cmbarton>

More information about the grass-dev mailing list