[GRASS5] v.transform semi-error

Michael Barton michael.barton at asu.edu
Thu Jan 29 11:41:39 EST 2004


Happy to try to clarify now I that I've figured out why I've been 
confused. When you use v.transform from the tcltk menu system, it says 
to input an ascii vector map. If you click the browse button (labeled 
"vector_ascii", as is the output map name browse button), it goes to 
the dig_ascii to search for a map. If you select a map from there it 
appears in the dialog window. However, when you try to run v.transform 
(clicking the "run" button) it says file not found.

The problem seems to be that the tcltk menu system has not been updated 
to reflect changes in v.transform. In the manual, it says binary vector 
file and v.transform from the command line works as specified there.


On Thursday, January 29, 2004, at 07:47  AM, 
grass5-request at grass.itc.it wrote:

> From: Markus Neteler <neteler at itc.it>
> Date: Thu Jan 29, 2004  6:01:36  AM America/Phoenix
> To: grass5 at grass.itc.it
> Subject: Re: [GRASS5] Testing Grass 5.3 - v.transform
> On Wed, Jan 28, 2004 at 10:20:17PM -0700, Michael Barton wrote:
>> Radim
>> Just wanted to let you know. I tested v.transform by typing in the 
>> name
>> of a binary vector file (the browse button looks in the dig_ascii
>> instead of dig folder). It worked just fine. Thanks for the tip.
> Michael,
> this is not clear to me:
> src/mapdev/v.transform/main.c
> [...]
>        old->gisprompt                  = "old,dig,vector";
> The version in 5.3-CVS refers to the dig file.
> Where did you find the reference to dig_ascii? Maybe in 5.0.3?
> Markus
>> On Monday, January 19, 2004, at 01:54 AM, Radim Blazek wrote:
>>> On Friday 16 January 2004 17:13, Michael Barton wrote:
>>>> As with GRASS 5.7, I've been doing considerable testing of GRASS 
>>>> 5.3.
>>>> Overall, it is highly stable and works very well. Here are a couple 
>>>> of
>>>> minor items that perhaps could be fixed before it is released as
>>>> stable.
>>>> 1. v.transform does not operate correctly, at least under Mac OSX. 
>>>> It
>>>> requires an ASCII vector file as input, looks in the dig_ASCII 
>>>> folder,
>>>> but will not recognize an ASCII vector file unless it is put 
>>>> (manually
>>>> and incorrectly) into the dig folder. It produces an incomplete 
>>>> output
>>>> file (header and attributes, but no vectors). This was a problem on 
>>>> an
>>>> earlier release; I have tried this on the the 12 January CVS 
>>>> snapshot
>>>> and it is still a problem.
>>> v.transform was rewritten to read and write vector binary file.
>>> Radim
>> ____________________
Michael Barton, Professor & Curator
Department of Anthropology
Arizona State University
Tempe, AZ  85287-2402

voice: 480-965-6262; fax: 480-965-7671

More information about the grass-dev mailing list