[GRASS5] 5.3 Cygwin, Tcl/Tk, NVIZ

Glynn Clements glynn.clements at virgin.net
Sat Mar 6 16:41:30 EST 2004

Richard Greenwood wrote:

> >>A couple things, neither is good news.
> >>
> >>1. Building 5.3 under Cygwin was successful with the 2004_01_03 
> >>snapshot, however the 2004_01_10 and 2004_02_28 snapshots both fail in 
> >>configure as follows:
> >>
> >>checking whether to use Tcl/Tk... yes
> >>checking for location of Tcl/Tk includes...
> >>checking for tcl.h... yes
> >>checking for tk.h... yes
> >>checking Tcl version... 8.3
> >>checking Tk version... 8.3
> >>checking for location of Tcl/Tk library... /usr/local/lib/tcl8.3
> >>checking for Tcl_Init in -ltcl... no
> >>checking for Tcl_Init in -ltcl... no
> >>checking for Tcl_Init in -ltcl8.3... no
> >>checking for Tcl_Init in -ltcl8.3... no
> >>checking for Tcl_Init in -ltcl83... no
> >>checking for Tcl_Init in -ltcl83... no
> >>configure: error: *** Unable to locate Tcl library.
> >>
> >>Is it possible that something changed in the 5.3 source between
> >>January 3 and 10 that would cause this?
> > 
> > 
> > There were two changes to configure[.in] between those dates:
> > 
> > revision 1.120
> > date: 2004/01/09 19:57:05;  author: glynn;  state: Exp;  lines: +3 -4
> > Don't generate makefiles in configure script
> > Only (re)build makefiles when necessary
> > ----------------------------
> > revision 1.119
> > date: 2004/01/05 10:26:25;  author: paul;  state: Exp;  lines: +46 -5
> > (1) Experimental shared libary support (--enable-gmake=no --enable-shared=yes)
> > (2) --with-gdal is now the default
> > (3) startup script now called grass53 (NAME_VER=53)
> > (4) Set LD_LIBRARY_PATH properly in Init.sh
> > 
> > However, neither of these directly touched the Tcl/Tk checks.
> > 
> > Look for the corresponding error messages in config.log.
> Here are the last couple dozen lines of my configure.log from the
> 2004_02_28 snapshot.

> cannot find -ltcl83

> cannot find -ltcl83

I need to see the case (assuming that their is one) which fails with a
different error. On any given system, four of the six attempts will
normally fail with a "cannot find" error.

The Tcl checks test for -ltcl, -ltcl8.3 and -ltcl83 (for the last two,
the exact version number is taken from <tcl.h>), both with and without
$DLLIB (which is set to the library which provides dlsym).

Depending upon what your Tcl library is actually called, two of the
three pairs will fail (if it's called libtcl8.3, the -ltcl and -ltcl83
pairs will fail; the -ltcl8.3 pair would be the interesting one).

> >>Although 5.3 did build, when running the Tck/Tk interface, I am unable 
> >>to close any of the dialog boxes. I do not consider it to run well 
> >>enough to be worth distributing, but Michael Barton had expressed 
> >>interest in a 5.3 binary distribution, and I am happy to make it 
> >>available if he or anyone else would like it.
> > 
> > 
> > Which window manager are you using? twm doesn't put a "close" button
> > in the title bar; you have to select "Kill" from the root menu then
> > click on a window. This probably won't work with a rootless X server.
> Well I wasn't using any windows manager. I was simply starting XWin.exe
> and running a text mode Bash shell. So the X windows appear as standard
> looking Microsoft Windows with 3 buttons on the left side of the title
> bar, but 'X' having no effect when clicked.

Using rootless mode (where each X window is a separate Windows window)
is one more source of potential problems. It would be better to use
the conventional mode (where there is a single window for the entire X
"screen") for testing.

Also, the more usual way to start the X server is with "startx".

> >>2. I have tried Glynn?s Cygwin NVWISH2.2 dated 3/3/2004 under both 5.0.3 
> >>and 5.3. Three panels open momentarily before the error pasted at the 
> >>bottom of this email. Comparing my Cygwin configuration with Glynn?s, a 
> >>notable difference is that I am using Xfree 4.3 while Glynn has 4.2 and 
> >>I have not been able to find 4.2 binary installations files to test with.
> >>
> >>A couple very general comments: Until recently I have always run GRASS 
> >>under Cygwin from the command prompt, rather than Tcl/Tk (and I have 
> >>only run Nviz under Linux). From the command prompt GRASS has run 
> >>entirely reliably and given me very good service, but these Tcl/Tk 
> >>problems are beyond my current ability to contribute much assistance with.
> >>
> >>==== 3/3/2004  NVWISH2.2 error message ====
> >>
> >>Error in startup script: integer value too large to represent
> >>     while executing
> >>"expr int([lindex $range 0])"
> >>     (procedure "mkcutplanePanel" line 55)
> >>     invoked from within

Hmm. That's exactly the same error which Scott reported yesterday:


That was with 5.0.3 on Linux, so this may not actually be a Cygwin
issue. He reported that it only occurred when using a specific map for
the colours. Try different options, e.g. "nviz -q".

> > This suggests that GS_get_zrange_nz() is returning garbage, possibly
> > because it can't find a surface.
> > 
> > It could be related to the X server, possibly to its GLX support. Can
> > you run the "glxinfo" and "glxgears" programs?
> glxgears runs correctly. Following is the output from glxinfo:

That looks sensible enough.

Glynn Clements <glynn.clements at virgin.net>

More information about the grass-dev mailing list