[GRASS-dev] Re: georectifier fixes

Otto Dassau otto.dassau at gmx.de
Thu Nov 2 04:11:33 EST 2006

On Thu, 2 Nov 2006 21:11:25 +1300
Hamish <hamish_nospam at yahoo.com> wrote:

> Otto Dassau wrote:
> > 
> > changing line 347 as proposed by Michael in
> > $GISBASE/etc/gm/georect.tcl
> > 
> > # 			catch {exec -- $cmd}
> > 			exec -- $cmd
> > 
> > sais sth. like:
> > 
> > Error: Parameter <group> not set:
> > 
> > maybe this helps: In GRASS 6.2.0RC3 it worked.
> try 
> exec -- $cmd --ui
> to force GUI mode.

now it works. Clicking on the edit/create button opens the i.group window.

> but is that running in current mapset (wrong) or switched to target
> mapset (correct)?

what do you mean here, it is running in current mapset. I list my procedure,
maybe I missunderstand:

- I start GRASS in spearfish/PERMANENT
- I Import a not geocoded map (topographic map)
- I start georectifier 
- I choose mapset PERMANENT
- I choose a new group and the map I want to rectify
- When I close the i.group window following message appears, but it still works:

child process exited abnormally
child process exited abnormally
    while executing
"exec -- $cmd --ui"
    (procedure "GRMap::group" line 17)
    invoked from within
    ("uplevel" body line 1)
    invoked from within
"uplevel \#0 $cmd"
    (procedure "Button::_release" line 18)
    invoked from within
"Button::_release .grstart.mf.frame.group.a"
    (command bound to event)
and set GCPs

- Then I select the group a just created
- I select the map to rectify 
- I start to set my GCPs and rectify.
- The result is ok and in stored the current mapset PERMANENT.

BTW: Is it intended that there are two ways to use the module? 

a) I set GCPs and fill in the appropriate coordinates in the 2nd column
b) I set GCPs and fill in the appropriate coordinates interactively opening a
second monitor with a reference map where I click in the map to find
the right coordinates. The coordinates are inserted in the rectifier then...


> Hamish

More information about the grass-dev mailing list