[GRASS-dev] Error in redrawing text layer in gis.m

Michael Barton michael.barton at asu.edu
Fri Nov 17 13:30:09 EST 2006

I think I found and fixed it.

It was not in grid but in the font setting environmental variable in

The script was resetting GRASS_FONT after running d.text.new. If GRASS_FONT
was not initially set, the script tried to set it to "". This caused a
failure in running d.frame -e for some reason. Anyway, if GRASS_FONT is
initially not set, it is unset (rather than being set to "") after running
d.text. I think this fixes the problem.

Please test and let me know.

Michael Barton, Professor of Anthropology
School of Human Evolution & Social Change
Center for Social Dynamics and Complexity
Arizona State University

phone: 480-965-6213
fax: 480-965-7671
www: http://www.public.asu.edu/~cmbarton

> From: "Patton, Eric" <epatton at nrcan.gc.ca>
> Date: Fri, 17 Nov 2006 09:03:35 -0500
> To: Hamish <hamish_nospam at yahoo.com>, Michael Barton <michael.barton at asu.edu>
> Cc: <grass-dev at grass.itc.it>
> Conversation: [GRASS-dev] Error in redrawing text layer in gis.m
> Subject: RE: [GRASS-dev] Error in redrawing text layer in gis.m
> HB:
>> Eric: any reason you aren't letting d.grid label the lines for you?
>> It should be formatted and rotated nicely (e.g. 44:26N)
>> (i.e. is there something about that you think could be improved?)
> The geogrid tool in gis.m doesn't allow you to change the font size. So I
> wanted to draw a lat-long grid over my UTM map display, but turn off graticule
> labels so I could use a dedicated text layer with larger labels instead. Like
> for making screenshots and figures for reports - the default text size of the
> geogrid labels are too small to read without squinting.
> PS - the text tool is the third button from the right on the top row of
> buttons in gis.m.
> ~ Eric.

More information about the grass-dev mailing list