[GRASS-dev] make on SMP [was: GRASS 6.3.0 release preparation]

Maciej Sieczka tutey at o2.pl
Wed Oct 17 11:47:37 EDT 2007

Markus Neteler wrote:
> On Wed, Oct 17, 2007 at 08:01:56AM +0200, Maris Nartiss wrote:

>> sorry but I'm not an make guru and thus see it simple: if I run comand
>> "make -j4" it should get along with it or fail with "err blah parallel
>> buld not supported". Current CVS version does neither of it.

> I hope we don't give up so early. Probably just a few Makefiles
> need to be fixed (basically, get the target order right therein).

>> As multicore CPU's are getting more popular, more and more users will be
>> trying to run "make -j X" and thus report failure as bug [1].

> Not always. As written yesterday, "make -j3" worked for me on my RHEL5
> box. Now testing with Mandriva.

>> If I can help with testing, drop me instructions. I have Gentoo ~x86
>> system (gcc version 4.2.1; GNU Make 3.81).

> Please help testing. Just run it and see if and where it fails.
> Then check the problematic Makefile(s) for correct order:
> http://grass.gdf-hannover.de/wiki/Development#GRASS_Makefile_writing

As for testing: I get the following errors with make -j3 on
Intel Core 2 6600 running 2.6.15-29-amd64-xeon (Ubuntu Dapper):

Errors in:


More information about the grass-dev mailing list