[GRASS-dev] make on SMP [was: GRASS 6.3.0 release preparation]

Maciej Sieczka tutey at o2.pl
Wed Oct 17 18:25:30 EDT 2007

Glynn Clements wrote:
> Maciej Sieczka wrote:
>>>> sorry but I'm not an make guru and thus see it simple: if I run comand
>>>> "make -j4" it should get along with it or fail with "err blah parallel
>>>> buld not supported". Current CVS version does neither of it.
>>> I hope we don't give up so early. Probably just a few Makefiles
>>> need to be fixed (basically, get the target order right therein).
>>>> As multicore CPU's are getting more popular, more and more users will be
>>>> trying to run "make -j X" and thus report failure as bug [1].
>>> Not always. As written yesterday, "make -j3" worked for me on my RHEL5
>>> box. Now testing with Mandriva.
>>>> If I can help with testing, drop me instructions. I have Gentoo ~x86
>>>> system (gcc version 4.2.1; GNU Make 3.81).
>>> Please help testing. Just run it and see if and where it fails.
>>> Then check the problematic Makefile(s) for correct order:
>>> http://grass.gdf-hannover.de/wiki/Development#GRASS_Makefile_writing
>> As for testing: I get the following errors with make -j3 on
>> Intel Core 2 6600 running 2.6.15-29-amd64-xeon (Ubuntu Dapper):
>> --
>> Errors in:
>> /home/maciek/src/straight/grass63/lib/gpde
>> /home/maciek/src/straight/grass63/imagery/i.vpoints
>> /home/maciek/src/straight/grass63/misc/m.cogo
>> /home/maciek/src/straight/grass63/raster/r.gwflow
>> /home/maciek/src/straight/grass63/raster/r.to.rast3elev
>> /home/maciek/src/straight/grass63/raster3d/r3.gwflow
>> /home/maciek/src/straight/grass63/vector/v.sample
> What errors, exactly?

That's all it says:

Started compilation: Thu Oct 18 00:07:37 CEST 2007
Errors in:
In case of errors please change into the directory with
error and run 'make'. If you get multiple errors, you need
to deal with them in the order they appear in the error log.
If you get an error building a library, you will also get
errors from anything which uses the library.
Finished compilation: Thu Oct 18 00:11:12 CEST 2007
make: *** [default] Error 1

If you'd like to see full make and configure output they are
here [1].

(Note this time there are less modules affected, and there
haven't been any commits to CVS between this and previous
CVS checkout + make run; I remembered to run "make
distclean" both times FWIW).

When I enter dirs mentioned  in "Errors in:", one by one,
and run "make -j3", they build fine and no errors are printed.



More information about the grass-dev mailing list