[GRASS-dev] wingrass: problems with some Makefiles

Moritz Lennert mlennert at club.worldonline.be
Tue Oct 23 00:57:18 EDT 2007

On Thu, October 18, 2007 07:55, Glynn Clements wrote:
> Moritz Lennert wrote:
>> Hello,
>> It took me awhile to respond to this, as I had the feeling that I did
>> something wrong reinstalling mingw/msys since I was getting more
>> compilation errors than before.
>> However, after double-checking with Benjamin's notes (thanks!), whether
>> my
>> installation was the problem. I currently use mingw 5.1.3 and
>> MSYS-1.0.11-2004.04.30-1, flex-2.5.33-MSYS-1.0.11,
>> bison-2.3-MSYS-1.0.11,
>> make-3.81-MSYS-1.0.11-1, reinstalled from scratch.
>> See attached error.log for all the errors. I erased the log of the
>> "normal" errors (i.* commands, and database drivers which fail because
>> of
>> the failure of sqlp).

> all point to lex.yy.o (and presumably lex.yy.c) being bogus. As
> lex.yy.c is generated by redirection, it will still be created (but
> will be empty or contain garbage) if flex fails.

Yep, was a problem with my flex install. I installed the gnuwin32 version
and now it works. Sorry for the noise.

>> > Try "make -p -C display/d.frame".
>> log attached.
> I think that this should fix the d.frame case:

Yes, this works now.

> v.voronoi.exe.exe?

This problem goes away with your fix. But there is a new one that shows up.

Now I have the following three problems (see also log attached):

1) lib/gis
/bin/install -c  -m 644 colors/CVS
/bin/install: `colors/CVS' is a directory
make: *** [/c/grasssrc/grass6/dist.i686-pc-mingw32/etc/colors/CVS] Error 1

2) raster3d/base (linked to the previous ?)
de.o: No such file or directory^M
make: *** [/c/grasssrc/grass6/dist.i686-pc-mingw32/bin/r3.info.exe] Error 1

3) vector/v.voronoi (looks like another problem with my MinGW
installation, but did not see this before)
/mingw/lib/libmingw32.a(main.o):main.c:(.text+0x104): undefined reference
to `WinMain at 16'^M
collect2: ld returned 1 exit status^M

-------------- next part --------------
A non-text attachment was scrubbed...
Name: error.log.gz
Type: application/gzip
Size: 4419 bytes
Desc: not available
Url : http://lists.osgeo.org/pipermail/grass-dev/attachments/20071023/dd4ef753/error.log.bin

More information about the grass-dev mailing list