[GRASS-dev] Re: [GRASS-user] modify feature's values interactively

Moritz Lennert mlennert at club.worldonline.be
Thu Mar 27 09:04:37 EDT 2008

[moving this to -dev]

On 27/03/08 13:27, Hamish wrote:
> Martin:
> http://grass.gdf-hannover.de/wiki/Image:Wxgui-vector-querying-gnulinux.png
> Moritz:
>> Cool !
>> However, I just can't get it to work:
>> I have
>> GRASS 6.3.svn (spearfish60):~ > v.db.connect -p roads
>> Vector map <roads at PERMANENT> is connected by:
> ...
>> Querying in display mode works as expected:
> ...
>> label : secondary highway, hard surface
>> But when I try to query it in edit mode, I get:
>> "No database record available"
> just a guess: you were not in the PERMANENT mapset when you tried this
> test? You can only edit maps in the current mapset (or at least that
> should be the case) -- and the same is true for DBs.
> If that is the problem here, I guess we need to add some more tests and
> more appropriate error messages.

Nice guess, but that's unfortunately not it. I get the same message with:

GRASS 6.3.svn (spearfish60):~ > g.copy vect=roads at PERMANENT,myroads

GRASS 6.3.svn (spearfish60):~ > v.db.connect -p myroads
Vector map <myroads at user1> is connected by:
layer <1> table <myroads> in database 
</home/mlennert/GRASS/DATA/spearfish60/user1/dbf> through driver <dbf> 
with key <cat>

I also get the same result with a map fields at user1 connected to a 
postgresql table.

BTW, Martin: I like the highlighting of the queried feature in the edit 
mode. Could this also be activated in the display mode (which maybe 
should be called "query" mode ?) ?


More information about the grass-dev mailing list