[GRASS-dev] failure compiling GRASS svn trunk on Mac OS X 10.4.11

Michael Barton michael.barton at asu.edu
Mon Mar 31 21:36:10 EDT 2008

I'm trying to begin to get caught with all the changes over the past  
couple weeks.

I updated from the SVN a couple hours ago, did a make distclean,  
installed new versions of William Kyngesburye's frameworks and tried  
to compile.

There was an initial problem with one of the frameworks (see below)  
that William fixed in very short order (Thanks!!). Following the fix,  
configure ran fine with no errors.

But when I tried to compile, I hit 2 new errors and an old one that I  
list below. The old one is vdigit with wxPython. I know that we're  
still wrestling with this, but wanted to report the current state on  
the Mac while I was covering other compile errors too. The new errors  
are in lib/external/shapelib and db/drivers/dbf

Errors in:


cmb-MBP-2:~/grass_dev/grass_src/lib/external cmbarton$ cd shapelib
cmb-MBP-2:~/grass_dev/grass_src/lib/external/shapelib cmbarton$ make
make lib
cc -dynamiclib -compatibility_version 6.3 -current_version 6.3 - 
install_name /Applications/Grass/GRASS-6.3.app/Contents/MacOS/lib/ 
libgrass_shape.dylib -o /Users/cmbarton/grass_dev/grass_src/dist.i686- 
apple-darwin8.11.1/lib/libgrass_shape.6.3.svn.dylib -L/Users/cmbarton/ 
grass_dev/grass_src/dist.i686-apple-darwin8.11.1/lib      OBJ.i686- 
apple-darwin8.11.1/shpopen.o OBJ.i686-apple-darwin8.11.1/dbfopen.o  && \
(cd /Users/cmbarton/grass_dev/grass_src/dist.i686-apple-darwin8.11.1/ 
lib; ln -f -s libgrass_shape.6.3.svn.dylib /Users/cmbarton/grass_dev/ 
ld: Undefined symbols:
/usr/bin/libtool: internal link edit command failed
make[1]: *** [/Users/cmbarton/grass_dev/grass_src/dist.i686-apple- 
darwin8.11.1/lib/libgrass_shape.6.3.svn.dylib] Error 1
make: *** [default] Error 2
cmb-MBP-2:~/grass_dev/grass_src/lib/external/shapelib cmbarton$


cmb-MBP-2:~/grass_dev/grass_src cmbarton$ cd ./db/drivers/dbf
cmb-MBP-2:~/grass_dev/grass_src/db/drivers/dbf cmbarton$ make
gcc -L/Users/cmbarton/grass_dev/grass_src/dist.i686-apple- 
darwin8.11.1/lib     -o /Users/cmbarton/grass_dev/grass_src/dist.i686- 
apple-darwin8.11.1/driver/db/dbf OBJ.i686-apple-darwin8.11.1/column.o  
OBJ.i686-apple-darwin8.11.1/cursor.o OBJ.i686-apple-darwin8.11.1/db.o  
OBJ.i686-apple-darwin8.11.1/dbfexe.o OBJ.i686-apple-darwin8.11.1/ 
describe.o OBJ.i686-apple-darwin8.11.1/driver.o OBJ.i686-apple- 
darwin8.11.1/error.o OBJ.i686-apple-darwin8.11.1/execute.o OBJ.i686- 
apple-darwin8.11.1/fetch.o OBJ.i686-apple-darwin8.11.1/listtab.o  
OBJ.i686-apple-darwin8.11.1/main.o OBJ.i686-apple-darwin8.11.1/ 
select.o OBJ.i686-apple-darwin8.11.1/str.o OBJ.i686-apple- 
darwin8.11.1/table.o OBJ.i686-apple-darwin8.11.1/create_table.o  - 
lgrass_dbmidriver -lgrass_dbmibase -lgrass_gis -lgrass_datetime - 
lz      -lgrass_dbstubs -lgrass_dbmibase -lgrass_gis -lgrass_datetime  
-lz      -lgrass_gis -lgrass_datetime -lz      -lgrass_gis - 
lgrass_datetime -lz      -lgrass_dbmibase -lgrass_gis - 
lgrass_datetime -lz       -lgrass_sqlp -lgrass_shape -lgrass_dbstubs - 
lgrass_dbmibase -lgrass_gis -lgrass_datetime -lz      -lgrass_gis - 
lgrass_datetime -lz      -lgrass_gis -lgrass_datetime -lz     - 
lgrass_datetime -L/Library/Frameworks/GDAL.framework/Versions/1.5/ 
unix/lib -lgdal  -lz
/usr/bin/ld: can't locate file for: -lgrass_shape
collect2: ld returned 1 exit status
make: *** [/Users/cmbarton/grass_dev/grass_src/dist.i686-apple- 
darwin8.11.1/driver/db/dbf] Error 1
cmb-MBP-2:~/grass_dev/grass_src/db/drivers/dbf cmbarton$


cmb-MBP-2:~/grass_dev/grass_src cmbarton$ cd ./gui/wxpython/vdigit
cmb-MBP-2:~/grass_dev/grass_src/gui/wxpython/vdigit cmbarton$ make
cc -dynamiclib -compatibility_version 6.3 -current_version 6.3 - 
install_name /Applications/Grass/GRASS-6.3.app/Contents/MacOS/lib/ 
libgrass6_wxvdigit.dylib -o OBJ.i686-apple-darwin8.11.1/ 
_grass6_wxvdigit.dylib -L/Users/cmbarton/grass_dev/grass_src/ 
dist.i686-apple-darwin8.11.1/lib      OBJ.i686-apple-darwin8.11.1/ 
cats.o OBJ.i686-apple-darwin8.11.1/digit.o OBJ.i686-apple- 
darwin8.11.1/driver.o OBJ.i686-apple-darwin8.11.1/ 
grass6_wxvdigit_wrap.o OBJ.i686-apple-darwin8.11.1/line.o OBJ.i686- 
apple-darwin8.11.1/select.o OBJ.i686-apple-darwin8.11.1/vertex.o - 
lgrass_vect -lgrass_dbmibase -lgrass_gis -lgrass_datetime -lz      - 
lgrass_dbmiclient -lgrass_dbmibase -lgrass_gis -lgrass_datetime - 
lz      -lgrass_gis -lgrass_datetime -lz      -lgrass_dgl - 
lgrass_dig2 -lgrass_gis -lgrass_datetime -lz     -lgrass_rtree  - 
lgrass_gis -lgrass_datetime -lz     -lgrass_linkm -lgrass_rtree  - 
lgrass_dig2 -lgrass_gis -lgrass_datetime -lz     -lgrass_rtree  - 
lgrass_dgl -lgrass_rtree -lgrass_linkm -lgrass_dbmiclient - 
lgrass_dbmibase -lgrass_gis -lgrass_datetime -lz      -lgrass_gis - 
lgrass_datetime -lz      -lgrass_dbmibase -lgrass_gis - 
lgrass_datetime -lz       -L/Library/Frameworks/GDAL.framework/ 
Versions/1.5/unix/lib -lgdal -lgrass_gis -lgrass_datetime -lz     -L/ 
Library/Frameworks/GDAL.framework/Versions/1.5/unix/lib -lgdal - 
lgrass_vedit -lgrass_gis -lgrass_datetime -lz     -lgrass_vect - 
lgrass_dbmibase -lgrass_gis -lgrass_datetime -lz      - 
lgrass_dbmiclient -lgrass_dbmibase -lgrass_gis -lgrass_datetime - 
lz      -lgrass_gis -lgrass_datetime -lz      -lgrass_dgl - 
lgrass_dig2 -lgrass_gis -lgrass_datetime -lz     -lgrass_rtree  - 
lgrass_gis -lgrass_datetime -lz     -lgrass_linkm -lgrass_rtree  -L/ 
usr/local/lib/wxPython-unicode-   -framework IOKit - 
framework Carbon -framework Cocoa -framework System -framework  
QuickTime  -lwx_macud-2.8  -L/Library/Frameworks/Python.framework/ 
Versions/2.5/lib/python2.5/config -ldl -lpython2.5 -lgdi
/usr/bin/libtool: can't locate file for: -lgdi
/usr/bin/libtool: file: -lgdi is not an object file (not allowed in a  
make: *** [OBJ.i686-apple-darwin8.11.1/_grass6_wxvdigit.dylib] Error 1

Suggestions are of course appreciated.


On Mar 31, 2008, at 5:23 PM, William Kyngesburye wrote:

> New version available.
> On Mar 31, 2008, at 6:34 PM, Michael Barton wrote:
> > OK. Thanks for checking
> >
> > Michael
> >
> > On 3/31/08 3:52 PM, "William Kyngesburye" <kyngchaos at kyngchaos.com>
> > wrote:
> >
> >> Is that configuring for GRASS?  Look in config.log to find a more
> >> useful reason why it couldn't find tiffio.h.
> >>
> >> Oh, wait, it's really not there.  Crap!  I was reorgranizing my  
> Xcode
> >> project and left the Tiger tiff headers private, though I did  
> get the
> >> Leopard tiff headers right.
> >>
> >> Stay tuned for an update...
> >>
> >> On Mar 31, 2008, at 5:34 PM, Michael Barton wrote:
> >>
> >>> William,
> >>>
> >>> I just updated to your current frameworks (any chance you can  
> put a
> >>> date on each of these so that I know which ones I need to  
> update?).
> >>>
> >>> When I tried a ./configure, I got an error about missing tiff  
> files.
> >>>
> >>>
> >>> ....
> >>> checking whether to use TIFF... yeschecking for location of TIFF
> >>> includes... /Library/Frameworks/UnixImageIO.framework/unix/
> >>> includechecking for tiffio.h... noconfigure: error: *** Unable to
> >>> locate TIFF includes.cmb-MBP-2:~/grass_dev/grass_src cmbarton$
> >>> Michael
> >>
> -----
> William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>
> http://www.kyngchaos.com/
> The equator is so long, it could encircle the earth completely once.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-dev/attachments/20080331/da38ce16/attachment-0001.html

More information about the grass-dev mailing list