[GRASS-dev] SQLite 3 "SQL logic error"

Benjamin Ducke benjamin.ducke at oxfordarch.co.uk
Wed Aug 26 10:15:02 EDT 2009

Dear all,

I have been trying in vain to store some very simple GRASS vector
map in an SQLite3 DBMS using v.out.ogr. The data consists of
only 93 3D points with attached integer and double attributes.
No complex shapes, timestamps, text or blobs.

Using v.out.ogr, I get:

ERROR 1: sqlite3_step() failed:
  SQL logic error or missing database

for all except the first record, which gets stored correctly
in the (new) database. It is not possible to test this with
an existing SQLite database file, because v.out.ogr in RC5
does not support the OGR "update" action.

I have searched the Trac system for clues and found one ticket
that may be related: http://trac.osgeo.org/grass/ticket/548

I have also tried this with different versions of SQLite and
on different Linux systems, but always with the same result.

My setup:

32Bit Gentoo Linux


SQLite 3.6.16

GDAL 1.6.1 (SQLite driver using native code, not linked
to spatialite)

Is there anybody here experiencing the same problems?
Any idea where to start looking? I am very interested in
making external SQLite support via OGR work, but have no
clue where to start looking to resolve the problem, so
any ideas are more than welcome!



Files attached to this email may be in ISO 26300 format (OASIS Open Document Format). If you have difficulty opening them, please visit http://iso26300.info for more information.

More information about the grass-dev mailing list