[GRASS-dev] Re: SQL inequality and GXW files

Joe Ostrowski jtostrowski at comcast.net
Sun Mar 15 23:13:08 EDT 2009

The "ampersand-lt-semicolon" got changed to "<" at the nabble site.   
Just to make sure the post makes sense I've changed the previous  
post.  See below...  Joe

> Subject: SQL inequality and GXW files
> I'm using 6.4.0RC3 on OSX 10.4.11 (Kyngesburye release) using the  
> WxPython GUI.  I set up a where clause for a vector display  
> (ATTR<>'ABC'), which works fine.  I then save the workspace as  
> "test.gxw".  No problem there.
> When I try to open the test.gxw workspace file I get the error  
> message:
> Error
> Reading workspace file <..../test.gxw>
> failed. Invalid file, unable to parse XML document.
> <unknown>:17:35: not well-formed (invalid token)
> I open up the file using emacs and it immediately flags the "<" in  
> the "<>" field:
> <parameter name="where">
>     <value>ATTR<>'ABC'</value>
> </parameter>
> since it believes the "<" is opening a markup tag.
> I edit the file to change "<>" to "ampersand-lt-semicolon ampersand- 
> gt-semicolon" and try to open the workspace file again.  This time  
> the workspace gets loaded just fine.  Tried to save with the SQL  
> "cat<10".  File saves OK but I get the same error when trying to  
> open that gxw file.  I change the "<10" to "ampersand-lt-semicolon  
> 10" and the file opens and the vector displays no problem.
> I guess the GXW save facility needs to check for the "<" symbol and  
> replace it with "ampersand-lt-semicolon"
> Thanks,
> Joe

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-dev/attachments/20090315/0695c798/attachment.html

More information about the grass-dev mailing list