[GRASS-dev] database driver errors from wish tcltk gui on mac - more info

Michael Barton michael.barton at asu.edu
Mon Mar 16 01:45:56 EDT 2009

On Mar 15, 2009, at 7:48 PM, Michael Barton wrote:

> On Mar 15, 2009, at 7:25 PM, William Kyngesburye wrote:
>> Start GRASS with the tcltk GUI as the default (g.gisenv  
>> set=GRASS_GUI=tcltk if it doesn't, and start GRASS again).  Select  
>> a mapset (or drag-n-drop a mapset to start GRASS).
>> Add a vector to the map.
>> Down at the bottom of the vector properties pane, click the "Show  
>> attribute data" button.
>> error
>> I also tried labelling a point vector (bugsites in spearfish) with  
>> one of its attributes, and that works.
> OK. I CAN duplicate this weird problem. Only with the autogui  
> startup. It gives a dbmi protocol error
> db.select table=archsites database=/Users/Shared/grassdata/ 
> Spearfish60_test/PERMANENT/dbf/ driver=dbf
> Bad file descriptor: dup r
> dbmi: Protocol error
> Unable to start driver <dbf>
> This command doesn't via tcltk, though it does work from the terminal.
> If you start up tcltk via g.gui tcltk&, it works fine.
> Anyone out there -- What happens in startup AFTER the TclTk gui is  
> launched that might make db.select work with the following?
> start up GRASS in TclTk GUI mode
> db.select does NOT work (error above)
> quit Tcltk
> g.gui tcltk&
> db.select DOES work
> Michael

Further tests. All of the db.* info modules except db.tables fail  
(with the same error, above) from TclTk when it is first started from  
Init.sh. This includes:

All of these work when the tcltk GUI is started from g.gui

Really weird. What is "dup r"???


More information about the grass-dev mailing list