[GRASS-dev] [GRASS GIS] #809: v.db.addtable consistently fails in winGrass

GRASS GIS trac at osgeo.org
Fri Nov 13 10:30:59 EST 2009

#809: v.db.addtable consistently fails in winGrass
 Reporter:  JonBall   |       Owner:  grass-dev at lists.osgeo.org
     Type:  defect    |      Status:  new                      
 Priority:  blocker   |   Milestone:  6.4.0                    
Component:  Vector    |     Version:  svn-trunk                
 Keywords:  addtable  |    Platform:  MSWindows Vista          
      Cpu:  x86-64    |  
 Platform: Vista
 grass obtained from: Trento Italy site
 grass binary for platform:  as Downloaded
 GRASS Version: 6.4.0SVN  (r39626) 2009-10-27

 v.db.addtable consistently fails but returns no error message.  When I try
 to use this command at the Windows Grass Command Line (Windows shell), I
 always get an empty shell prompt:

 GRASS 6.4.0svn (spearfish60)> v.db.addtable map=mysoils layer=2 col="left
 r,right integer"

 The only apparent way to proceed it to type 'exit' at the shell prompt and
 the command will terminate without creating a table.  I am trying to
 reproduce the script in the documentation for v.to.db
 (http://grass.itc.it/grass64/manuals/html64_user/v.to.db.html - "Upload
 category numbers of left and right area, to an attribute table of
 boundaries common for the areas").

 This error is consistent whatever data I try and use, whether it is the
 demo Spearfish60, North-Carolina or some other data.

 I have reproduced the same error on two independent installations of
 winGrass on two different machines (both using the same pre-compiled

 I have tried switching to sqlite (same error).  I have tried re-installing

Ticket URL: <http://trac.osgeo.org/grass/ticket/809>
GRASS GIS <http://grass.osgeo.org>

More information about the grass-dev mailing list