[GRASS-dev] grass/wx 6.4 problems on Debian sid.

Francesco P. Lovergine frankie at debian.org
Wed Oct 7 08:55:18 EDT 2009

The wxpython interface is still seriously unusable in grass RC5 on unstable. I
found the same result using current 6.4.0 branch r39426.

Trying to edit any vector files this is the result:

Traceback (most recent call last):
"/usr/lib/grass64/etc/wxpython/gui_modules/vdigit.py", line
233, in __init__
line 334, in __init__
    this = _grass6_wxvdigit.new_Digit(*args)
TypeError: in method 'new_Digit', argument 2 of type
'wxWindow *'

Currently there are at least a couple of differences among sid and e.g.
Ubuntu karamic (where it seems working):

swig 1.3.39 instead of 1.3.36
wxpython 2.8.7 instead of 2.8.10

I suspect the main problem is swig, due to past experiences. What are
the reference versions suggested currently? I would suggest to
distribute swig generated stuff by default and allowing re-building
on demand. That solved various swig-related problems in the past.

I'm doing some other trials to discover if my guess is true.

Francesco P. Lovergine

More information about the grass-dev mailing list