[GRASS-dev] wxNviz volumes

Helena Mitasova hmitaso at ncsu.edu
Thu Jun 30 23:28:43 EDT 2011


more things to report:

- I tried volumes in wxnviz but I did not get too far - the GUI does not see any of my 3d rasters -
the browser for 3D raster maps shows the mapsets but nothing in them

- there appears to be an issue with automatic loading of raster when opening the Data Tab:
-- I have map1 and map2 in GIS manager.
-- I switch off map1 but I keep map2 on
-- switch view to 3d.
-- wxnviz opens correctly with map2
-- when I switch to tab Data, map1 is loaded as raster map - I would have expected map2
--I tried with more rasters and it looks like it
always picks up the raster that was added the first  (it is lowest in the list)
rather than the one which is highlighted

-nviz2/cmd does not compile, when I run make on it I get the following
/System/Library/Frameworks/CoreServices.framework/Headers/../Frameworks/CarbonCore.framework/Headers/MacTypes.h:503: error: redefinition of ‘struct Rect’
lipo: can't figure out the architecture type of: /var/folders/-w/-wN910nTFamsDLR+fBkvB++++TI/-Tmp-//ccw2Iwjp.out
make: *** [OBJ.i386-apple-darwin10.7.0/vector.o] Error 1

nviz does not compile either ( I have some issue with my TclTk ), perhaps that is causing problems with nviz_cmd?


On Jun 27, 2011, at 4:09 PM, Anna Kratochvílová wrote:

> Hello,
> I've just tried to fix the problems with light model and fringe, I hope it will work for you. 
> I'm going to work on nviz_cmd now and with certain parameters I get segmantation fault. So it would be helpful if you could tell me about any bugs you are aware of and I'll try to fix them. 
> Best regards
> Anna

More information about the grass-dev mailing list