[GRASS-dev] 6.4.2rc3 this week, then 6.4.2 by the holidays?

Anna Kratochvílová kratochanna at gmail.com
Sun Nov 27 08:32:31 EST 2011

Hi Helena,

2011/11/26 Helena Mitasova <hmitaso at ncsu.edu>:
> Anna,
> thank you for backporting wxnviz, I just compiled it and it runs great, even with some highly specialized data
> (e.g. terrestrial lidar scans at 0.01m resolution).
> There are few things that still have issues (mostly features that never really worked in nviz and may be only Mac related)
> Appearance:
> - scale bar does not work with my terrestrial lidar x,y data (but it worked in grass7 with different data)

Try it again (make clean), I think has Martin fixed it recently. It
works for me.

> - add legend > OK: nothing gets drawn in 3D but the legend shows up when I switch to 2D
> but when I clicked delete scalebar (which was not drawn),
> my surface disapeared but the legend showed up along with white and black background
> (which I assume was supposed to be transparent, because when I moved the legend the surface
> was under it - we already discussed this, it may be my problem, because it works for Michael).

I really don't know what to do with this issue, I can't test it and I
don't have any idea what should I test.

> General
> - when I go from 3D view to 2D and then back to 3D I lose most of my settings
> (viewing position, zexag, fringe size etc. - this would be OK if I could get a warning and question
> whether I want to save my 3D viewing state before switching)
> - similarly, when I add volume to Map layers I lose my view settings and the 3D view goes back to default

both should work now

> Volumes:
> - change of region by g.region seems to be ignored (or I missed something), I had to restart GRASS with the new region

Library is initialized only when you switch to 3D for the first time,
it should be initialized every time

> to get the 3D region for volumes right. Given that the default top, botom is 1,0, if GRASS
> starts with the default 3D region settings volumes do not work because there is just one level.
> - isosurfaces work with my terrestrial lidar data but the slices don't, it seems that it is due
> my resolution being 0.3m, when I change it to 1m I get at least some limited slicing
>  - this may be in ogsf becuase slices in nviz do not work with this data either

I don't have any experience with volume resolution in grass, so I
really don't know what's happening.
Could I get this data to test it?

> - changing color to constant did not change the color of the isosurface

This works for me. Can you see any error message?

> - when working with volumes the following error message shows up :
> 'CheckListBox' object has no attribute 'SetChecked'

This is quite weird because in wxpython documentation this method
really exists. Maybe it could be some problem with versions. I tried
another method, hope it works.

Please, could you update the list of known issues on wiki?

Best regards,

> Thank you,
> Helena
> On Nov 25, 2011, at 10:22 AM, Anna Kratochvílová wrote:
>> Hi,
>> On Tue, Nov 22, 2011 at 10:42 AM, Martin Landa <landa.martin at gmail.com> wrote:
>>> Hi,
>>> the latest wxNviz is available only in trunk. Together with Anna we
>>> are planning in these days backport to devbr6 and immediately after
>>> releasing 6.4.2 to backport wxNviz to `relbr64` to have enough time
>>> for testing. So at this point I will disable wxNviz in `relbr64`.
>>> Martin
>> wxNviz is now in 6.5, testing welcomed
>> Anna

More information about the grass-dev mailing list