[GRASS-dev] [GRASS GIS] #1339: Corrupted Shapefile causes buffer overflows, assetions etc.

GRASS GIS trac at osgeo.org
Mon Aug 20 15:33:41 PDT 2012

#1339: Corrupted Shapefile causes buffer overflows, assetions etc.
 Reporter:  marisn       |       Owner:  grass-dev@…              
     Type:  defect       |      Status:  new                      
 Priority:  normal       |   Milestone:  6.4.3                    
Component:  Vector       |     Version:  svn-releasebranch64      
 Keywords:  rtree        |    Platform:  Unspecified              
      Cpu:  Unspecified  |  
Changes (by neteler):

  * version:  unspecified => svn-releasebranch64
  * milestone:  6.4.2 => 6.4.3


 I imported the attached file into GRASS 70: v.in.ogr worked. Then I tried

 v.out.ascii augstumpunkti1
 *** glibc detected *** v.out.ascii: realloc(): invalid next size:
 0x0000000001409a00 ***

 It crashes in GRASS 7.svn r52794 in lib/vector/Vlib/ascii.c, line 529

 Import with 6.4.svn still fails:
 GRASS 6.4.3svn (PERMANENT):/tmp/broken_shapefile > v.in.ogr
 augstumpunkti1.shp out=augstumpunkti1 --o
 WARNING: Datum <Not_specified_based_on_GRS_1980_ellipsoid> not recognised
          by GRASS and no parameters found
 Projection of input dataset and current location appear to match
 WARNING: Vector map <augstumpunkti1> already exists and will be
 Layer: augstumpunkti1
 Counting polygons for 60 features...
 Importing map 60 features...
 Building topology for vector map <augstumpunkti1_tmp>...
 Registering primitives...
 v.in.ogr: split_q.c:69: RTreeClassify: Assertion `!p->taken[i]' failed.
 Aborted (core dumped)

Ticket URL: <http://trac.osgeo.org/grass/ticket/1339#comment:2>
GRASS GIS <http://grass.osgeo.org>

More information about the grass-dev mailing list