[GRASS-dev] minimal wxPython version

Margherita Di Leo dileomargherita at gmail.com
Tue Mar 19 10:54:57 PDT 2013

Ciao Anna,

On Tue, Mar 19, 2013 at 2:39 PM, Anna Kratochvílová
<kratochanna at gmail.com>wrote:

> Hi all,
> I would like to change minimal required version of wxPython [1].
> Currently we support (theoretically) version (released 2007).
> I suggest to change it to (2009), for example was
> shipped with Ubuntu 10.04 LTS.

Same for debian stable. From my point of view it's pretty safe to switch
version as you suggest.

> The reason is obvious: wxGUI is limited
> by this requirement. Even the version is pretty old so I
> think this won't hurt anybody. Any objections?
> [1] http://grass.osgeo.org/grass70/source/snapshot/REQUIREMENTS.html
> PS - There is a similar problem with Python version (required 2.4).
> Some interesting features start with 2.5 but usually we can live
> without it. Any opinions?

Personally I don't know anyone still using 2.4.

Thank you

Best regards,

Margherita DI LEO
Postdoctoral Researcher

European Commission - DG JRC
Institute for Environment and Sustainability (IES)
Via Fermi, 2749
I-21027 Ispra (VA) - Italy - TP 261

Tel. +39 0332 78 3600
margherita.di-leo at jrc.ec.europa.eu

Disclaimer: The views expressed are purely those of the writer and may not
in any circumstance be regarded as stating an official position of the
European Commission.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20130319/b0d7e2d1/attachment-0001.html>

More information about the grass-dev mailing list