[GRASS-dev] [GRASS GIS] #1849: Cannot create a new GRASS Location using a custom proj4 string

GRASS GIS trac at osgeo.org
Fri May 10 05:46:28 PDT 2013

#1849: Cannot create a new GRASS Location using a custom proj4 string
 Reporter:  voncasec                       |       Owner:  grass-dev@…              
     Type:  defect                         |      Status:  new                      
 Priority:  critical                       |   Milestone:  6.4.3                    
Component:  Projections/Datums             |     Version:  unspecified              
 Keywords:  proj4, location wizard, wxgui  |    Platform:  Linux                    
      Cpu:  x86-64                         |  

Comment(by hamish):

 Replying to [comment:11 hamish]:
 > setup by custom proj terms hopefully fixed & working ok in devbr6
 > as of r56176 (please test with your local!), similar fixes for
 > epsg remain todo.

 epsg, custom proj terms still not right in wingrass+proj 4.8.0, but
 looking ok on linux+proj 4.7.0.

 It seems that the g.proj -t flag is needed with the 'g.proj -jw' calls to
 get the datum transform on the summary page on wingrass+4.8.0, and the -t
 flag is also needed in grass.create_location() (in core.py, at least for
 epsg-mode) for the g.proj call there.

 On wingrass 6.5 I tried 'g.proj -c epsg=27200 datumtrans=2
 loc=test_without_t' right on the command line, and without using the -t
 flag meant that the datum transform was not added to the resulting
 PROJ_INFO file, instead the default proj4-heuristics option was used. With
 the -t flag it respected the datumtrans= option.

 > an existing bug in the custom proj terms (maybe elsewhere
 > too) is if you select datum transform opt `0` from the
 > list (i.e. don't specify transform opts) it picks the
 > grass default one anyway.

 this is a bug in g.proj ignoring `datumtrans=0`, or rather falling back to
 the grass datum table default (this time, proj4 heuristics choose
 differently). As I'm not entirely sure if that should be classed as a bug
 or intended feature, I'll file it as another ticket. (seems ok in wingrass
 6.5 + proj 4.8.0 but not linux 6.5 + proj 4.7.0)


Ticket URL: <https://trac.osgeo.org/grass/ticket/1849#comment:12>
GRASS GIS <http://grass.osgeo.org>

More information about the grass-dev mailing list