[GRASS-dev] Some minor TGIS issues in GRASS 7.1

Blumentrath, Stefan Stefan.Blumentrath at nina.no
Tue Aug 26 11:37:24 PDT 2014

Hei Sören,

good to hear. I can only say that I am very happy with the TGIS framework. It is already very useful as it is!

Meanwhile I came across two other issues in GRASS 7.1 (r61095):
1) On my system (Ubuntu 14.04 LTS 64bit) t.list gives no output and does not finish, so I have to cancel it with CRTL-C and kill the processes manually.
2) In some cases t.rast.aggregate does not manage to gather all map information when nprocs is > 1. After "Gathering map informations" I get: "ERROR:  Unable to open header file for raster map".
Although, all maps are properly produced, the STDS is empty. The same command with nprocs=1 works fine. I have not figured out how exactly this behavior is triggered, because it does not occure in all parallel aggregations I tried (other t.rast.aggregate commands with nproc=10 worked fine), in again other cases with more than 1 core, after the error named above it works in a second run...

Von: Sören Gebbert [soerengebbert at googlemail.com]
Gesendet: Montag, 25. August 2014 17:55
An: Blumentrath, Stefan
Cc: grass-dev at lists.osgeo.org
Betreff: Re: [GRASS-dev] Some minor TGIS issues in GRASS 7.1

Hi Stefan,
many thanks for your feedback, it is really appreciated.

We will fix this bug in a major code review and overhaul. Thomas
(Author of the temporal algebra code) and i are revisiting the
temporal algebra at the moment. We will introduce several changes
regarding the functionality and the algebra syntax. The temporal
algebra code is still very experimental and needs further testing. We
are still working on the general concept of the algebra, that will
eventually result in a paper.

Best regards

2014-08-22 13:22 GMT+02:00 Blumentrath, Stefan <Stefan.Blumentrath at nina.no>:
> One additional thing:
> t.rast.mapcalc2 does not seem to read STDS from other mapsets. I get a parse error regardless if I use full map names with mapset specified (then expression parsing seems to break at the "at") or if I add the other mapset to the current search path and do not specify the mapset in the expression (in the latter case the modul complains that the map cannot be found in the current mapset)?
> Anyone who can confirm?
> Cheers
> Stefan
> _______________________________________________
> grass-dev mailing list
> grass-dev at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/grass-dev

More information about the grass-dev mailing list