[GRASS-dev] Error reading null row 2725 for <MASK>

Paulo van Breugel p.vanbreugel at gmail.com
Wed Aug 27 01:13:08 PDT 2014

When running several r.mapcalc in a loop (via R) the function stops with an

ERROR: Error reading null row 2725 for <MASK>

The row number varies. This seems to happen at random, and when I repeat
the same r.mapcalc calculation that stopped with the error before, things
run without problem.

I tried after removing the mask, and this time no problem so it may have to
do something with the MASK? (as these error messages only occur once in a
while, I can't be completely sure it only happens when a MASK is defined).

I ran it through R, using the execGRASS() function of the spgrass6 package.
I ran the same, but using the system call instead of execGRASS. Still got
the same error messages. I therefore guess this has nothing to do with R?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20140827/659a86d2/attachment.html>

More information about the grass-dev mailing list