[GRASS-dev] Error reading null row 2725 for <MASK>

Markus Neteler neteler at osgeo.org
Wed Aug 27 11:20:58 PDT 2014

On Wed, Aug 27, 2014 at 3:25 PM, Paulo van Breugel
<p.vanbreugel at gmail.com> wrote:
> I forgot to mention that I am using GRASS 7.1 (rev 61757, had it before with
> rev 61413, but I think I had a similar problem about a year ago).
> On Wed, Aug 27, 2014 at 10:13 AM, Paulo van Breugel <p.vanbreugel at gmail.com>
> wrote:
>> When running several r.mapcalc in a loop (via R) the function stops with
>> an error:
>> ERROR: Error reading null row 2725 for <MASK>

The error comes from read_null_bits() in


Maybe some off_t definition is missing?

>> The row number varies. This seems to happen at random, and when I repeat
>> the same r.mapcalc calculation that stopped with the error before, things
>> run without problem.

Please tell us also
- how many raster cells are involved
- how many files are opened in the loop?

>> I tried after removing the mask, and this time no problem so it may have
>> to do something with the MASK? (as these error messages only occur once in a
>> while, I can't be completely sure it only happens when a MASK is defined).
>> I ran it through R, using the execGRASS() function of the spgrass6
>> package. I ran the same, but using the system call instead of execGRASS.
>> Still got the same error messages. I therefore guess this has nothing to do
>> with R?

Could you "simulate" the loops in a GRASS script outside of R to see
if it the same?


More information about the grass-dev mailing list