[GRASS-dev] [GRASS-user] GRASS for Mac 64bit, wxPython 3, maybe fix for SIP problem - please test

Michael Barton Michael.Barton at asu.edu
Thu Jun 2 08:06:09 PDT 2016

Thanks for the report Adam. When you say you fixed the path, what exactly did you do?

Michael Barton
School of Human Evolution &Social Change
Center for Social Dynamics & Complexity
Arizona State University

...Sent from my iPad

On Jun 2, 2016, at 6:54 AM, Adam Dershowitz <adershowitz at exponent.com<mailto:adershowitz at exponent.com>> wrote:

Looks like you missed a library, or path.  I just tried it on 10.11 with SIP enabled, and I get this error:

$ '/Applications/GRASS-7.3.app/Contents/MacOS/grass.sh'; exit

Rebuilding Addon HTML manual pages index...

Rebuilding Addon menu...

Python 2.7.10 found.

Cleaning up temporary files...

Starting GRASS GIS...

dyld: Library not loaded: /usr/local/lib/libintl.8.dylib

  Referenced from: /Applications/GRASS-7.3.app/Contents/MacOS/lib/libgrass_gis.7.3.svn.dylib

  Reason: image not found

Traceback (most recent call last):

  File "/Applications/GRASS-7.3.app/Contents/MacOS/gui/wxpython/gis_set.py", line 31, in <module>

    from core import globalvar

  File "/Applications/GRASS-7.3.app/Contents/MacOS/gui/wxpython/core/globalvar.py", line 29, in <module>

    from core.debug import Debug

  File "/Applications/GRASS-7.3.app/Contents/MacOS/gui/wxpython/core/debug.py", line 77, in <module>

    Debug = DebugMsg()

  File "/Applications/GRASS-7.3.app/Contents/MacOS/gui/wxpython/core/debug.py", line 39, in __init__


  File "/Applications/GRASS-7.3.app/Contents/MacOS/gui/wxpython/core/debug.py", line 45, in SetLevel

    self.debuglevel = int(grass.gisenv().get('WX_DEBUG', 0))

  File "/Applications/GRASS-7.3.app/Contents/MacOS/etc/python/grass/script/core.py", line 953, in gisenv

    s = read_command("g.gisenv", flags='n')

  File "/Applications/GRASS-7.3.app/Contents/MacOS/etc/python/grass/script/core.py", line 458, in read_command

    process = pipe_command(*args, **kwargs)

  File "/Applications/GRASS-7.3.app/Contents/MacOS/etc/python/grass/script/core.py", line 433, in pipe_command

    return start_command(*args, **kwargs)

  File "/Applications/GRASS-7.3.app/Contents/MacOS/etc/python/grass/script/core.py", line 372, in start_command

    if debug_level() > 0:

  File "/Applications/GRASS-7.3.app/Contents/MacOS/etc/python/grass/script/core.py", line 1536, in debug_level

    _debug_level = int(gisenv().get('DEBUG', 0))

  File "/Applications/GRASS-7.3.app/Contents/MacOS/etc/python/grass/script/core.py", line 953, in gisenv

    s = read_command("g.gisenv", flags='n')

  File "/Applications/GRASS-7.3.app/Contents/MacOS/etc/python/grass/script/core.py", line 461, in read_command

    return handle_errors(returncode, stdout, args, kwargs)

  File "/Applications/GRASS-7.3.app/Contents/MacOS/etc/python/grass/script/core.py", line 329, in handle_errors


grass.exceptions.CalledModuleError: Module run None ['g.gisenv', '-n'] ended with error

Process ended with non-zero return code -5. See errors in the (error) output.

ERROR: Error in GUI startup. See messages above (if any) and if necessary, please report this error to the GRASS developers.

On systems with package manager, make sure you have the right GUI package, probably named grass-gui, installed.

To run GRASS GIS in text mode use the -text flag.



Saving session...

...copying shared history...

...saving history...truncating history files...


-- Adam

From: grass-user <grass-user-bounces at lists.osgeo.org<mailto:grass-user-bounces at lists.osgeo.org>> on behalf of Michael Barton <Michael.Barton at asu.edu<mailto:Michael.Barton at asu.edu>>
Date: Wednesday, June 1, 2016 at 7:50 PM
To: GRASS developers list <grass-dev at lists.osgeo.org<mailto:grass-dev at lists.osgeo.org>>, grass-user grass-user <grass-user at lists.osgeo.org<mailto:grass-user at lists.osgeo.org>>
Subject: [GRASS-user] GRASS for Mac 64bit, wxPython 3, maybe fix for SIP problem - please test

I just posted a new binary for GRASS 7.3 built fully 64 bit, with wxPython to the GRASS for Mac site (http://grassmac.wikidot.com<https://urldefense.proofpoint.com/v2/url?u=http-3A__grassmac.wikidot.com&d=CwMFAg&c=t0wRGL5ICVzH157W8C8Wew&r=5usL3OGqXabRLtSzGmh8YEvbco28TaiOmWcn6rCn8wM&m=g-_vMK6bUb2L_0yJaa2OvFkqicaKTyNnPnCZOxN-i6s&s=jF8bboxVJboLDUrCG5V5xobtx6ig-JEF92VM_t_MXA4&e=>)

It turns out the previous "64bit" GRASS binary still ran 32bit Python. I had to hack the python_wrapper.py file, but this one is fully 64bit AFAICT. I also tried some hacks that might be a way to solve the inability to run GRASS on El Capitan with SIP enabled. There are a couple of known bugs in the wxPython 3.x GUI

1. The most serious is switching to 3D mode and back to 2D mode leaves one of the map display menu buttons corrupted. It seems the only thing you can do is to close the map display and open a new one.

2. There are also some popup lists (e.g., for switching mapsets) that do not behave as they should. You cannot select an item with a mouse (but you can select with arrow keys and <return>) unless you hit <escape> to destroy part of the control. Then you can use the mouse to click something.

Please let us know if you encounter any other bug or strange behavior.

Also,  and importantly if anyone is running El Capitan, it would be great if you could reenable SIP (if you've turned it off) and see if this version runs.  Of course, maybe I've "fixed" it so that it only runs on my system and crashes on everyone else's.

C. Michael Barton
Director, Center for Social Dynamics & Complexity
Professor of Anthropology, School of Human Evolution & Social Change
Head, Graduate Faculty in Complex Adaptive Systems Science
Arizona State University

voice:  480-965-6262 (SHESC), 480-965-8130/727-9746 (CSDC)
fax: 480-965-7671 (SHESC),  480-727-0709 (CSDC)
www: http://www.public.asu.edu/~cmbarton<https://urldefense.proofpoint.com/v2/url?u=http-3A__www.public.asu.edu_-7Ecmbarton&d=CwMFAg&c=t0wRGL5ICVzH157W8C8Wew&r=5usL3OGqXabRLtSzGmh8YEvbco28TaiOmWcn6rCn8wM&m=g-_vMK6bUb2L_0yJaa2OvFkqicaKTyNnPnCZOxN-i6s&s=DWmxIXQue0rzESF_0QnhgEylY9V-yUIeg1aKl9gQ9Yc&e=>, http://csdc.asu.edu<https://urldefense.proofpoint.com/v2/url?u=http-3A__csdc.asu.edu&d=CwMFAg&c=t0wRGL5ICVzH157W8C8Wew&r=5usL3OGqXabRLtSzGmh8YEvbco28TaiOmWcn6rCn8wM&m=g-_vMK6bUb2L_0yJaa2OvFkqicaKTyNnPnCZOxN-i6s&s=4wxcas1zdXuTlR2aqJsCv88HfPWUcHLeed-Z1RQ1svE&e=>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20160602/0c8c4cad/attachment-0001.html>

More information about the grass-dev mailing list