[GRASS-dev] [GRASS GIS] #3057: Problems with Numpy and matplotlib after updating through OSGeo4W

GRASS GIS trac at osgeo.org
Thu Jun 9 07:33:00 PDT 2016

#3057: Problems with Numpy and matplotlib after updating through OSGeo4W
 Reporter:  veroandreo   |      Owner:  grass-dev@…
     Type:  defect       |     Status:  new
 Priority:  normal       |  Milestone:  7.2.0
Component:  Python       |    Version:  unspecified
 Keywords:               |        CPU:  Unspecified
 Platform:  MSWindows 7  |
 [from grass-user ML]

 I updated grass stable and trunk at my mum and brother's PCs (windows 7 -
 32 bits and windows 10 - 64 bits, respectively) by means of OSGeo4W

 When starting both versions (7.0.4 and 7.3 r68614) in both computers, I
 get a message saying Numeric, numarray or NumPy not found.

 Then, when I tried to use g.gui.timeline or g.gui.tplot, I got an error
 saying matplotlib and pyparsing must be installed.

 I run the update again and specifically checked for numpy, matplotlib and
 pyparsing under libs, and all of them were there already selected for
 "update" or "keep", so dunno...

 All was fine before the update, in 7.0.3 and 7.1 no such issues in any of
 the computers. In case it matters, I'm also using MSYS for bash shell in
 windows and the settings are:

 set GRASS_SH=%OSGEO4W_ROOT%\apps\msys\bin\sh.exe
 set GRASS_PYTHON=%OSGEO4W_ROOT%\bin\python.exe
 set PYTHONHOME=%OSGEO4W_ROOT%\apps\Python27

 Has anybody had a similar issue? Do I have to manually select or install
 some other lib/dependency??

Ticket URL: <https://trac.osgeo.org/grass/ticket/3057>
GRASS GIS <https://grass.osgeo.org>

More information about the grass-dev mailing list