[GRASS-dev] t.rast.mapcalc: The temporal map type of the sample dataset must be interval

Pietro peter.zamb at gmail.com
Fri Feb 9 01:11:51 PST 2018

Hi Martin,

Sorry to resume such old thread, but I have the same issue.

On Wed, Nov 30, 2016 at 11:08 PM, Martin Landa <landa.martin at gmail.com>
> 2016-11-30 23:05 GMT+01:00 Veronica Andreo <veroandreo at gmail.com>:
>> Maybe the method=equal, which is the default method for t.rast.mapcalc,
>> not defined for time instance data (?).
>> Have you tried changing it? For example, setting method=start? Perhaps in
>> that way, only start time is evaluated to perform the operation between
>> series.
> thanks for tip, anyway changing method to 'start' doesn't seem to have
> any effect, I am getting the same error. Ma

Did you find a way to go on?

I have two temporal rasters:

$ *t.rast.list Rbeam_2000m at Rbeam_2000m | head*
Rbeam_2000m_20120101_00|Rbeam_2000m|2012-01-01 00:00:00|None
Rbeam_2000m_20120101_01|Rbeam_2000m|2012-01-01 01:00:00|None
Rbeam_2000m_20120101_02|Rbeam_2000m|2012-01-01 02:00:00|None


$ *t.rast.list Rbeam_250m at Rbeam_250m | head *
Rbeam_250m_20120101_00|Rbeam_250m|2012-01-01 00:00:00|None
Rbeam_250m_20120101_01|Rbeam_250m|2012-01-01 01:00:00|None
Rbeam_250m_20120101_02|Rbeam_250m|2012-01-01 02:00:00|None

But when I try to execute the t.rast.mapcalc I got:

$ *t.rast.mapcalc input=Rbeam_2000m at Rbeam_2000m,Rbeam_250m at Rbeam_250m
expression='(Rbeam_250m - Rbeam_2000m)/Rbeam_250m' output=Rbeam_norm_diff
basename=Rbeam_norm_diff nprocs=4 method=start --o*
Starting temporal sampling...
ERROR: The temporal map type of the sample dataset must be interval
No samples found for map calculation

I have to delete and register the maps with `t.register -i`? Now I'm going
to try this!
Any hints?

Best regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20180209/6555c313/attachment-0001.html>

More information about the grass-dev mailing list