[GRASS-dev] Issue with double conditional in r.mapcalc (WinGRASS) and real life test of the aconda 7.5dev on Mac

Vaclav Petras wenzeslaus at gmail.com
Tue Feb 20 05:20:40 PST 2018

On Tue, Feb 20, 2018 at 6:16 AM, Yann Chemin <dr.yann.chemin at gmail.com>

> We tried to use the command prompt to enter the scripts, but it made
> trouble so we tried on the wxGUI Console, and we found it worked mostly,
> until we started entering more complex if statements. But that was after we
> had to remove quotes to enter the r.mapcalc script successfully anyway.

If I may, here is what I think happened (based on our continuous experience
and Helmut having hard time reproducing it). You had troubles, you removed
quotes, perhaps also fixed the issue without knowing it. All was fine. Then
started to use expressions with && and || which were failing without
quotes. More complicated expressions like those with nested ifs were
failing too. Those were failing perhaps because there was forgotten space
here and there which can happen because they are long/complex and the
console in GUI is not in monospaced font* so spaces are quite narrow and
can blur with the surrounding characters.

* Which is probably a bug.

I'm sorry for the monospace and quotes bugs which were certainly not
helping you, but my current assessment is that these are only the two bugs
involved here. But of course we want r.mapcalc to be rock solid, so please
test & report more if you think it's needed.

> Would that be related to the issues with internationalisation (
> https://trac.osgeo.org/grass/ticket/3500)?

Anything is possible and our continuous successful use is with English
locale, but my guess is that that's not the case.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20180220/76ed5836/attachment.html>

More information about the grass-dev mailing list