[GRASS-dev] Compiling and Installing GRASS GIS on Windows

Helmut Kudrnovsky hellik at web.de
Sat Jan 6 11:59:27 PST 2018

Neev Mistry wrote
> Dear GRASS GIS developers, I am Neev Mistry (Eric1234), a student
> participating in the 2017 Google Code-In. I have been having some trouble
> with compiling and installing GRASS GIS on Windows. I have followed the
> instructions on https://trac.osgeo.org/grass/wiki/CompileOnWindows up
> until
> the step where I have to run the package.sh compilation script. I ran all
> four commands and got no output from any (See Image 1.png). I cannot find
> an error.log file or mswindows/osgeo4w/package.log. When I go to the
> folder
> for OSGEO4W64 and click on Apps, GRASS GIS is not installed there. I have
> installed GRASS GIS 7.2.2 earlier using the installer, and I do also have
> the OSGeoLive Virtual Machine, but trying to compile the source code is
> not
> working for me. Thank you so much for your help.

according to your screenshot, you're on a windows 64bit box and try to
compile GRASS trunk. am I right?

if you want to compile trunk on a windows 64bit box, then you have to use
following command:

PACKAGE_POSTFIX=-daily OSGEO4W_POSTFIX=64 ./mswindows/osgeo4w/package.sh

just tried here on my win 10 64bit box, configure and compiling works with
the command above.

when compilation starts, error.log lives in:


and package.log lives in 


have a look into this folder:


is there a file called configure-stamp in this folder? if yes, then just
delete this file and try it again and report back here.

while writing this mail, my test compilation on my windows 10 64bit box

in package log I can see:

Started compilation: Sat Jan  6 20:42:36 CET 2018
Errors in:
No errors detected.
Finished compilation: Sat Jan  6 20:56:52 CET 2018
Sat Jan  6 20:56:52 CET 2018: FINISHED make AFTER 14m18s
Sat Jan 6 20:56:52 CET 2018: STARTING make install

best regards
Sent from: http://osgeo-org.1560.x6.nabble.com/Grass-Dev-f3991897.html

More information about the grass-dev mailing list