[GRASS-dev] Error in GRASS GUI startup

Kiersten kiersten.bergquist at siu.edu
Fri Dec 20 15:26:56 PST 2019

Hello devs,

I'm very new to GRASS-GIS. Many jobs in my field want some level of
familiarity with GIS so, I wanted to get ahead and try seeing if I can learn
a free version of GIS on my own (since I know that non-GRASS GIS systems can
be costly). 

I followed along the step-by-step tutorial and had GRASS 7.8 installed.
Everything was fine until I downloaded the NC dataset (using the "location
wizard"). I tried to then start a GRASS session with that data, and all of a
sudden the program closed out. I tried to re-open GRASS, when I was hit with
the following message:

ERROR: Error in GUI startup. See messages above (if any) and if necessary,
please report this error to the GRASS developers.
On systems with package manager, make sure you have the right GUI package,
probably named grass-gui, installed.
To run GRASS GIS in text mode use the --text flag.
Use '--help' for further options
     grass78 --help
See also: https://grass.osgeo.org/grass78/manuals/helptext.html

I tried and tried to download the GUI package, but the websites led me in
circles and nothing was working. I tried the sites recommended, I tried
downloading aptitude in case I was doing anything wrong, but nothing. I'm
pulling my hair out! 

I'm really not sure what to do. Technology is not my strong point (heck,
even running R or SAS for classes is still a struggle for me), so I figured
I would turn to asking real people for help, since the websites haven't been
much help for me. Please let me know if I should ask this on a different
part of the forum.

I would really appreciate some help. I've found with computer stuff, there
is no such thing as over-explaining it to me! Thank you very much in

Sent from: http://osgeo-org.1560.x6.nabble.com/Grass-Dev-f3991897.html

More information about the grass-dev mailing list