[GRASS-dev] compiling GRASS-latest - configure fails with Unable to locate PostgreSQL includes

Zoltan zoltans at geograph.co.za
Sat Jun 19 02:32:35 PDT 2021

I'm having trouble with:
./configure --enable-64bit --enable-largefile --with-libs=/usr/lib64 
--with-postgres=yes --with-odbc=yes --with-opencl=yes 
--with-gdal=/usr/local/bin/gdal-config -with-pdal=/usr/bin/pdal-config 
checking for png_read_image in -lpng... yes
checking whether to use PostgreSQL... yes
checking for location of PostgreSQL includes... 
checking for libpq-fe.h... no
*configure: error: *** Unable to locate PostgreSQL includes.*

I tried various folders and then downloaded/unzipped 
https://www.postgresql.org/ftp/source/v13.3/ *postgresql-13.3.tar.bz2*
into my dev folder - but still get the above 'includes' error.

I'm working on Ubuntu 20.04 and downloaded GRASS src as follows:

zls at ZolAW17ubuntu:~/dev$ git clone https://github.com/OSGeo/grass.git 
then cd grass-latest_20210619.git and ./configure (as above)

Thanks in advance,


Zoltan Szecsei GPrGISc 0031
Geograph (Pty) Ltd.
GIS and Photogrammetric Services

Cape Town, South Africa.

Mobile: +27-83-6004028 (Signal, not WhatsApp)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20210619/19ae6421/attachment.html>

More information about the grass-dev mailing list