Angus Carr apcarr at FLASH.LakeheadU.CA
Tue Mar 26 07:00:00 EST 1996

On Mon, 25 Mar 1996, Helena Mitasova wrote:
> Has anybody used s.surf.tps with this version of GRASS?
> Do you get any warnings or error messages from
> the program, have you checked your region and resolution properly
> (run d.sites with the same region you are using when running
> s.surf.tps)

For what it's worth, when I was running the older binaries for Linux, I 
tried s.surf.tps on a sites file that was correctly formatted, using 
perfectly correct settings. It tossed out all my points. I was a little 
I immediately walked over to the SUN box, which, through some 
jiggery-pokery with nfs and userid numbers, used exactly the same files 
as the Linux box.
It worked first time, with no thought required on my part. I then ran the 
program on the SUN for the rest of the time I needed it.

As a thought- could it be that PC's running Linux are using the 
other-endian data structures for multi-byte integers compared to most 
UNIX boxes? I have run into this problem with i.in.erdas too. It screwed 
me up for quite a while setting up an ERDAS export filter that I tested 
against i.in.erdas. 


More information about the grass-user mailing list