v.to.rast:error G_set_window()

Justin Hickey jhickey at impact1.hpcc.nectec.or.th
Thu Jul 8 09:55:43 EDT 1999


Good to hear that bugs are being fixed in GRASS. I also had the same
problem with the resulting map being filled with NULL values. However, I
would like to point out a possible related problem to Agus's problem that
I reported shortly after the release of GRASS5.0beta. The problem is with
r.in.ascii and r.in.poly and possibly others. The similarity is that the
resulting map is full of NULLs. I haven't checked current sources for 5.0
so I don't know if this was fixed but your message reminded me of it. Here
is my original post.


I just installed GRASS 5.0 beta and have found problems with some of the
commands. The r.in.ascii and the r.in.poly commands don't seem to work. I
set up a 10x10 test region and tried to read in the following ascii file

north:      5
south:      0
east:       5
west:       0
rows:       5
cols:       5

100.0 200.0 300.0 200.0 100.0
100.0 200.0 300.0 200.0 100.0
100.0 200.0 400.0 200.0 100.0
100.0 200.0 300.0 200.0 100.0
100.0 200.0 300.0 200.0 100.0

Running r.in.ascii with this file produces a blank raster map of nulls -
no data exists in the map. This same file worked fine in the old floating
point code.  Next I thought I would try r.in.poly but this program
produced the same results. 

Anyone have any ideas as to what could be wrong?

Thank you for your time.


I never heard from Baylor concerning this problem so I just thought I
would remind people about it.


Jazzman (a.k.a. Justin Hickey)  e-mail: jhickey at hpcc.nectec.or.th
High Performance Computing Center
National Electronics and Computer Technology Center (NECTEC)
Bangkok, Thailand
People who think they know everything are very irritating to those
of us who do.  ---Anonymous

Jazz and Trek Rule!!!

More information about the grass-user mailing list