[GRASSLIST:2792] Re: r.cost produces no output??

Eric G. Miller egm2 at jps.net
Mon Dec 17 01:19:31 EST 2001

On Sat, 01 Dec 2001 17:43:03 -0700, Michael Barton <michael.barton at asu.edu> wrote:

> I am trying to work my way through the various grass modules. Today, I 
> tried to produce cost surfaces using r.cost. I am using grass 5.0pre2 
> with the tcltk interface. I tried it with the Spearfish data set, trying 
> both with a DEM and a slope map as the base maps. I tried both x,y 
> coordinates and a site map as points from which to compute the cost 
> surface. I turned on verbose mode to check the output.
> It seemed to run and produced no error messages.
> The problem is that it produces no apparent output. I have tried varying 
> the name of the output file and having it write to an existing file. 
> Nothing produced any output. I have write permissions in the relevant 
> directory and have successfully done other things (e.g., a viewshed 
> test).

I have hopefully fixed some crash and burn bugs in r.cost.  Don't know
if it'll fix what you were seeing, but it solved a couple problems I
saw.  You can get a copy from CVS or wait for the next release...

Eric G. Miller <egm2 at jps.net>

More information about the grass-user mailing list