[GRASSLIST:2044] Re: Newbie Grass5.0.0pre1 compilation problem

Simon Parker STP838 at bham.ac.uk
Mon Jul 2 03:19:25 EDT 2001

Hi Markus,

thanks for the help. I tried these checks and results were:
	plenty of disc space
	no .gislock
	could create it and remove it

So I tried another tack. I updated my glibc, since there was an update
available from Mandrake (7th May 2001), this was a bugfix - fixes a problem
with Oracle Universal Installer. Thought this was worth a shot. Also
downloaded the CVS snapshot and recompiled. This did the trick - it compiled
fine. So I don't know which one was causing the problem, but hopefully this
might help someone else out.

I still have a problem though, neithter of the two modules I wanted to use
(r.in.ntf2 and m.in.ntf) would compile for me. For example for r.in.ntf2,
when I run gmake5, it compiles about 4 or 5 files, then I get:

/usr/bin/ld: cannot open output file /r.in.ntf2 permission denied

Now I know that I don't have permission to write to this directory as user,
but this doeasn't seem to be the right place for the file. Looking through
the  Gmakefile it seems as though the variable $(BIN_CONTRIB_CMD) is
undefined. I tried setting this manually and the compile gets further but
then gives an error:

/usr/local/grass/src/libes/gis/flat.c undefined reference to 'deflate

Is this some reference to the now replaced LZW compression libraries? If so
is there anything simple I can do to change the code to reflect this? Thanks

Simon Parker

> -----Original Message-----
> From: owner-GRASSLIST at baylor.edu [mailto:owner-GRASSLIST at baylor.edu]On
> Behalf Of Markus Neteler
> Sent: 28 June 2001 11:18
> To: GRASSLIST at baylor.edu
> Subject: [GRASSLIST:2027] Re: Newbie Grass5.0.0pre1 compilation problem
> Hi Simon,
> On Wed, Jun 27, 2001 at 11:15:09AM +0100, Simon Parker wrote:
> > Hi Everyone
> >
> > I wonder if anyone can help me out.
> >
> > I have a box running Mandrake8.0 and have been trying to compile
> > grass5.0.0pre1 from source (not CVS snapshot, dated 20 May
> 2001). I have in
> > the past successfully installed the grass5.0.0pre1 precompiled
> binary and it
> > worked fine, but wanted to use some additional modules so
> needed the source
> > files to compile these. I tried unsucessfully to compile from
> source having
> > removed the previous installation but gave up and reinstalled
> my Linux OS
> > (drastic I know but it was getting messy).
> >
> > Installing onto the fresh OS, the compilation seemed to go ok,
> it reported
> > that it had compiled sucessfully. However after I install and
> try to run I
> > get the following error:
> >
> > Unable to properly access /home/simon/.gislock5, Please notify to system
> > personel.
> >
> > I run ./configuration and make as user and make install as
> root. Trying to
> > start grass5 as user.
> Well, above sounds all fine. Please try following *directly* after getting
> this message:
> # is there enough space:
> df -k .
> # does the file exist?
> more /home/simon/.gislock5
> # can you create it (permission problem):
> touch /home/simon/.gislock5
> #if yes, remove afterwards
> rm /home/simon/.gislock5
> Maybe one of these tests will fail (please report).
> > I noticed that this message is reported in the FAQ in relation
> to installing
> > the precompiled binary to a system with an older glibc (2.0)
> and that the
> > binaries are built on glibc2.1. My system is based on glibc2.2
> is this the
> > root of the problem and if so what can I do about it? Anyone have any
> > similar problems?
> That's an old story not relevant with current systems (especially if you
> compiled locally).
> Regards
>  Markus Neteler

More information about the grass-user mailing list