[GRASSLIST:2048] Re: Newbie Grass5.0.0pre1 compilation problem

Eric G. Miller egm2 at jps.net
Mon Jul 2 21:22:05 EDT 2001

On Mon, Jul 02, 2001 at 08:19:25AM +0100, Simon Parker wrote:
> Hi Markus,
> thanks for the help. I tried these checks and results were:
> 	plenty of disc space
> 	no .gislock
> 	could create it and remove it
> So I tried another tack. I updated my glibc, since there was an update
> available from Mandrake (7th May 2001), this was a bugfix - fixes a problem
> with Oracle Universal Installer. Thought this was worth a shot. Also
> downloaded the CVS snapshot and recompiled. This did the trick - it compiled
> fine. So I don't know which one was causing the problem, but hopefully this
> might help someone else out.
> I still have a problem though, neithter of the two modules I wanted to use
> (r.in.ntf2 and m.in.ntf) would compile for me. For example for r.in.ntf2,
> when I run gmake5, it compiles about 4 or 5 files, then I get:
> /usr/bin/ld: cannot open output file /r.in.ntf2 permission denied
> Now I know that I don't have permission to write to this directory as user,
> but this doeasn't seem to be the right place for the file. Looking through
> the  Gmakefile it seems as though the variable $(BIN_CONTRIB_CMD) is
> undefined. I tried setting this manually and the compile gets further but
> then gives an error:

Must be the ntf modules haven't been updated recently (I don't think
they are built by default).  There is no $(BIN_CONTRIB_CMD) anymore.
Change it to $(BIN_CMD).

> /usr/local/grass/src/libes/gis/flat.c undefined reference to 'deflate
> end'(?)
> Is this some reference to the now replaced LZW compression libraries? If so
> is there anything simple I can do to change the code to reflect this? Thanks
> again.

Add $(XDRLIB) to the $(CC) line (it includes the -lz switch).

Eric G. Miller <egm2 at jps.net>

More information about the grass-user mailing list